Kyle Vanditmars kylevan at
Wed Jan 24 04:52:59 UTC 2007

On Tue, 2007-01-23 at 19:55 -0500, Maurice Murphy wrote:
> Hi everyone,
> I'm still having problems getting a reliable connection to my two
> box/Linksys router Windows network.  I appear to connect now and again
> by frequently clicking on the Reload button.  So when I get to the
> Windows network icon, double click on it, I now and again get an icon
> for MSHOME.  If I double click on it, I may get one computer but not
> the other or neither, but seldom both at once.  I have to think this
> is a bit of a showstopper, especially as my prime printer is connected
> to my XP box, not the Ubuntu box, which is the host.
> I have tried disabling ipv6, which reportedly can cause problems.
> This gave no improvement.  I've rebooted the wired modem and the
> router, which got me to the present state. (Before I had absolutely no
> connection.)  I have re-installed Samba.  Nothing seems to get me the
> reliable LAN connection that I so desperately need.
> Any help on this issue would be most gratefully accepted!  
> My second problem relates to the mounting of my removable storage, a
> 160Gb hard drive that plugs in to my HP box.  This drive is not
> recognized from a cold boot.  But mounts every time with a second
> reboot.  Strange, eh?
> Maybe I should give the whole rig a swift kick!  I would hate to be
> driven back to Windows because of these two difficulties because I
> really like Ubuntu.
> Perhaps I should put in bug reports, although I'm not quite sure how?
> Maurice from Nepean
> :-)   :-)   :-) 

For the SMB sharing, the SAMBA package doesn't actually handle your LAN
browsing, it allows the Linux machine to share folders to other Windows

The reloading shouldn't affect your printing in any way.  In fact, I
have the exact same problem, and printing to both networked printers in
my house works fine.  From what I understand, this is simply a problem
with Nautilus (the file manager).  There is a way to set a default
workgroup for Nautilus, and this will make all of the network shares on
that workgroup appear in the main "network servers" gnomevfs entry

Open the configuration editor, you can either add it to your
applications menu or open the run program dialog (alt+F2) and enter
"gconf-editor".  When it opens, look in the tree on the left, open the
"system" folder, and then the "smb" folder.  Within there should be a
setting called workgroup - it's listed in the right-side pane.  By
default it's blank, but if you enter your workgroup there, you'll get
the various network shares every time (at least it works for me).

I'm not sure about the removable storage problem.  Have you tried
hotplugging the drive after everything is booted?  I'm assuming it's a
USB device, if so there's no harm in trying that.

More information about the ubuntu-ca mailing list