Printers and scanners installation

Jack Bowling jbinpg at shaw.ca
Sat Jan 13 01:31:19 UTC 2007


On Fri, Jan 12, 2007 at 12:43:39AM -0800, Don and/or Mila Trombley wrote:
> I have a HP deskjet 930c printer and a Hp Scanjet 4300c which I wish to 
> install.
> When I tried to type in:
> sudo apt-get install build-essential python2.4-dev python2.4-qt3 
> libcupsys2-dev libsnmp9-dev libipeg62-dev lsb libtoolsautomake1.9 
> libusb-dev   <enter>
> 
> Notes: Xubuntu 6.1 reports: package Python 2.4-dev is not available, but 
> is referred to by another package. this may mean that the package is 
> missing, has been obsoleted,
> or, is only available  from another source.  However the following 
> packages replace it:   python2.4
> E: Package  python2.4-dev has no installation candidate. et  al........I 
> retyped the lines with the suggested recommendations,....and still end 
> up with more of the same.
> So, what can I do to get these things working?

On my Edgy box:

====================
$ apt-cache show python2.4-dev
Package: python2.4-dev
Priority: optional
Section: python
Installed-Size: 4764
Maintainer: Ubuntu Core Developers <ubuntu-devel at lists.ubuntu.com>
Original-Maintainer: Matthias Klose <doko at debian.org>
Architecture: i386
Source: python2.4
Version: 2.4.4~c1-0ubuntu1
Depends: python2.4 (= 2.4.4~c1-0ubuntu1)
Suggests: libc6-dev | libc-dev
Filename: pool/main/p/python2.4/python2.4-dev_2.4.4~c1-0ubuntu1_i386.deb
Size: 1503362
MD5sum: 932668a2c428d93cff99a39ad76ceab7
SHA1: 0b47334eaa214c273d99ce05fd0f793c288871c7
SHA256: 8f2b9fc984376f791871f5c57adcee41579fc0d3614d272eba77f303cffb26a4
Description: Header files and a static library for Python (v2.4)
 Header files, a static library and development tools for building
 Python (v2.4) modules, extending the Python interpreter or embedding
 Python (v2.4) in applications.
 .
 Maintainers of Python packages should read README.maintainers.
Bugs: mailto:ubuntu-users at lists.ubuntu.com
Origin: Ubuntu
Task: kubuntu-desktop
====================

And...

===============
$ apt-cache policy python2.4-dev
python2.4-dev:
  Installed: 2.4.4~c1-0ubuntu1
  Candidate: 2.4.4~c1-0ubuntu1
  Version table:
 *** 2.4.4~c1-0ubuntu1 0
        500 http://us.archive.ubuntu.com edgy/main Packages
        100 /var/lib/dpkg/status
===============

So you should be able to pick it up without problem with a stock install
since it is in the main repository.

Jack Bowling
Prince George, BC



So the code is there. Not sure why you aren't picking it up. Perhaps you
need to add 







More information about the ubuntu-ca mailing list