Getting Microphone to work in Ubuntu

Dave M G martin at
Sun May 7 15:16:08 UTC 2006

Ubuntu Canada,

I'm using Dapper 6.06. I'm a newbie with Linux. I know Dapper is a beta 
or alpha release, but I installed it without realizing that, and having 
worked with it as long as I have, it seems I'm in too deep to consider 
getting out now.

I'm having the following problem with my microphone: it doesn't work. 
The sound card outputs sound beautifully. I just can't get any input.

I've made sure to un-mute the microphone in the window that comes up by 
double clicking the speaker icon in the top-right of the screen.

I've selected to ensure that ALSA is installed via Synaptic, and I 
downloaded ALSA-tools and a few other ALSA related applications for good 
measure. To be honest, I don't entirely know what ALSA is, beyond that 
is a sound manager of some kind.

And then I ran the command "amixer" at the command prompt, and opened a 
can of worms:
dave at homebase:~$ amixer
ALSA lib confmisc.c:1107:(snd_func_refer) Unable to find definition 
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_refer 
returned error: No such file or directory
ALSA lib confmisc.c:242:(snd_func_getenv) error evaluating default
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_getenv 
returned error: No such file or directory
ALSA lib conf.c:3962:(snd_config_expand) Evaluate error: No such file or 
ALSA lib control.c:817:(snd_ctl_open_noupdate) Invalid CTL default
amixer: Mixer attach default error: No such file or directory

My gut instinct is that these errors need to be resolved before I can 
have any hope of getting the mike to work.

Any advice would be much appreciated.

Thank you.

Dave M G

More information about the ubuntu-ca mailing list