D-Link and Ndiswrapper

Tee Jay Rosene teejayrosene at gmail.com
Mon Dec 18 23:08:30 UTC 2006


Thanks for the awesome info! I haven't tried it yet, but I'm definitely
hitting that up tonight. I hope it works out; I've been banging my head off
this issue for a while.
I'll keep everyone posted...

Hi, Tee Jay.

Which version of Ubuntu are you using? Many of the D-link adapters actually
work in Ubuntu without the need for ndiswrapper. Ndiswrapper should be a
last resort only for cards known not to work in linux. Unfortunately much of
the documentation seems to points users towards it unnecessarily.

If it is one of the Dlink cards based on the Atheros chip (my AirPlus is) it
should work out of the box in Dapper, while in Edgy you need to install the
restricted modules for your kernel version.

I would start with the assumption that it works (since it does on mine). So
the first thing you should do is remove the ndiswrapper stuff completely.

If you're on Edgy, search synaptic for restricted-modules, install the
package for your architecture (probably 'generic' or 'i386'), reboot, and
then it should be detected.

If you're on Dapper I suggest you reboot after removing ndiswrapper.

Once you've rebooted, check System>Administration>Networki
ng, and see if the
wireless card is listed. If there is an entry for wireless networking there,
then your card has been detected.

If the card is still not being detected, then I would first check that the
pcmcia card bus and other laptop doodads are working properly - search the
forums and the internet for linux on your particular computer.

You may want to try booting the kernal with options such as noapic or
acpi=off, to see if that works, the former was necessary on one of my
laptops for it to recognise the soundcard, wifi and pcmcia bus on hoary.

Once it's detected:
1. Turn off any security on your wireless network
2. Install network-manager and network-manager-gnome (assuming you're on
Ubuntu)
3. Restart Gnome. You should see a network icon in the top righthand. Click
it. Does it give you wireless network options? If so, sign onto your
network.
4. Once you have it working, then you can enable the security, and network
manager will disconnect you and ask you for the WEP passphrase/whatever. If
you are using WPA security, then you have to install some other packages, so
search for that in the forums.

Hope that helps.

Brendan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-ca/attachments/20061218/d351675d/attachment.html>


More information about the ubuntu-ca mailing list