D-Link and Ndiswrapper

Tee Jay Rosene teejayrosene at gmail.com
Sat Dec 16 21:05:25 UTC 2006


I don't have any questions *per se, *I do want to include my experience with
Ndiswrapper so far, to better facilitate others who would also like to use
this programme; essentially I want to participate in Ubuntu Canada by
jotting down some of the problems I'm encountering in my attempt to get WiFi
working on Ubuntu. Although I don't have a solution, I guess this is my way
to participate in the open source community, and more particularly, Ubuntu
Canada.

I'm trying to get a D-Link "Air Plus Extreme G" card to work on an older IBM
Thinkpad (model 1161). I know this card works with the hardware because it
worked all right when I had Windows 2000 installed as the operating system.
There are four different versions of this specific card, and the one I own
is version B4. Consequently I downloaded the corresponding driver for the
card and used Ndiswrapper to "wrap" the driver. The card was then detected,
however I could not get it to work.

Because the driver I downloaded was an updated version, I also tried to use
the version that was on the installation disk that came with the card.
Again, the same results. The card was detected as being present, but I was
unable to activate it—the lights were not blinking, etc.

I know this is not Ubuntu's fault, but rather the card manufacturer's and
that giant proprietary conglomerate that has made my older Ethernet card
incompatible with Ubuntu. Luckily Ubuntu and the open source community
always has ingenious work-arounds for such situations such as mine, and I
need to find and/or learn how to do this.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-ca/attachments/20061216/2b5fa232/attachment.html>


More information about the ubuntu-ca mailing list