[Bug 556595] [NEW] Burned iso image corrupted

f3a97 stefano.doni at gmail.com
Tue Apr 6 16:25:22 BST 2010


Public bug reported:

Binary package hint: brasero

Hi,

I wanted to try the new ubuntu lucid beta 1. I went out a bought a CD-
RW. I burned the ubuntu iso on it with brasero on my Karmic PC, and
checked the md5sum. It failed:

ste at b-laptop:~$ md5sum /dev/cdrom 
md5sum: /dev/cdrom: Input/output error

First of all I checked the downloaded ISO, but it was ok. So I tried
another PC (always equipped with ubuntu 9.10), and got the same exact
results.

At this point, the culprit is the new CD-RW disk. I went out and bought
another and different one: TDK the former, Verbatim the latter.

I repeated the above steps, and got the same results! Incredible.

So I tried some other burning programs. First of all, I did a complete
CD-RW blank with cdrecord. Then, I tried again to burn the image from
command line. From that run, I've actually seen the problem:

ste at b-laptop:~$ sudo cdrecord -v speed=2 Downloads/ubuntu-10.04-beta1-desktop-i386.iso
...
Starting new track at sector: 0
Track 01:  675 of  675 MB written (fifo 100%) [buf 100%]   4.0x.
Track 01: Total bytes read/written: 707854336/707854336 (345632 sectors).
Writing  time: 1154.268s
Average write speed   4.0x.
Min drive buffer fill was 100%
Fixating...
Errno: 5 (Input/output error), close track/session scsi sendcmd: no error
CDB:  5B 00 02 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 03 00 00 00 00 0A 00 00 00 00 72 01 00 00
Sense Key: 0x3 Medium Error, Segment 0
Sense Code: 0x72 Qual 0x01 (session fixation error writing lead-in) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 11.533s timeout 480s
cmd finished after 11.533s timeout 480s
wodim: Cannot fixate disk.

As you can see, actually the burn process was not completing correctly.
Hence, the md5sum was failing.

Too bad, I did not managed to understand why wodim could not fixate the
disk.

As a last resort, I tried burning with k3b. And, guess what? It
succeeded!

ste at b-laptop:~$ md5sum /dev/cdrom 
7ddbfbcfcc562bae2e160695ec820e39  /dev/cdrom


I think we have a problem with cdrecord and brasero!

I'm going to attach some logs, please feel free to ask if more info is
needed!

Thanks

ProblemType: Bug
Architecture: i386
Date: Tue Apr  6 17:11:13 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
NonfreeKernelModules: wl
Package: brasero 2.28.2-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: brasero
Uname: Linux 2.6.31-20-generic i686

** Affects: brasero (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: apport-bug i386

-- 
Burned iso image corrupted
https://bugs.launchpad.net/bugs/556595
You received this bug notification because you are a member of Ubuntu
Burning Team, which is subscribed to brasero in ubuntu.



More information about the Ubuntu-burning mailing list