[Bug 72900] Cdrecord segfaults with when burning audio CD with many tracks

David Heath david at davidheath.org
Wed Nov 22 18:51:07 GMT 2006

Public bug reported:

Binary package hint: cdrecord


I just encountered a problem with cdrecord when trying to burn an audio
CD containing 86 tracks. I originally encountered this problem when
running via k3b, but the same thing happens when I run this command on
the command line:

$ /usr/bin/X11/cdrecord.mmap -v gracetime=2 dev=/dev/hdc speed=12
-raw96r driveropts=burnfree -eject -text -useinfo -audio -shorttrack
/tmp/kde-sam/k3bCdCopy0/Track01.wav [...cut out 84 more for
legibility...] /tmp/kde-sam/k3bCdCopy0/Track86.wav


Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Joerg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <cdrtools at packages.debian.org>.
      The original author should not be bothered with problems of this version.

/usr/bin/X11/cdrecord: Warning: Running on Linux-2.6.15-27-686
/usr/bin/X11/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/X11/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
TOC Type: 0 = CD-DA
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
Using libscg version 'debian-0.8debian2'.
/usr/bin/X11/cdrecord: Warning: using inofficial version of libscg (debian-0.8debian2 '@(#)scsitransp.c 1.91 04/06/17 Copyright 1988,1995,2000-2004 J. Schilling').
Driveropts: 'burnfree'
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'SONY    '
Identifikation : 'CD-RW  CRX300E  '
Revision       : 'KYS2'
Device seems to be: Generic mmc2 DVD-ROM.
Current: 0x0009
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009 (current)
Profile: 0x0008
Profile: 0x0002
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1422080 = 1388 KB
FIFO size      : 4194304 = 4096 KB
Encoding speed : 238x (17777 sectors/s) for libedc from Heiko Ei�eldt
pregap1: -1
Segmentation fault

as you can see the program segfaults without burning anything.

I re-ran the exact same command but with only 1 audio track and it
worked OK.

Here's some info on my system:

$ uname -a
Linux crystal 2.6.15-27-686 #1 SMP PREEMPT Sat Sep 16 02:13:27 UTC 2006 i686 GNU/Linux

Also, I've set cdrecord to be suid root.

I imagine I can work around this by making an ISO image, so I wouldn't
classify this as a 'major' problem, but all the same I thought I'd
report it .. less technical users might not understand how to work
around it.

Thanks for a great distro!

David Heath

** Affects: cdrtools (Ubuntu)
     Importance: Undecided
         Status: Unconfirmed

Cdrecord segfaults with when burning audio CD with many tracks

More information about the Ubuntu-burning mailing list