How to Report: Intel Gibabit Ethernet (82541PI) Problems After Upgrade to Hardy

Damon Timm damontimm at
Thu Dec 18 00:49:10 GMT 2008

Hi everyone -

I turned to this list because I wanted advice on how to file a bug --
I'm new to that, so wanted to make sure I am doing it right.

Here is the short story: after upgrading from Dapper to Hardy, my
gigabit ethernet card stopped performing at gigabit speeds.  I've
tried using ethtool to force it to use the 1000 speed, but it doesn't
work.  I am using Ubuntu Server for my NAS -- gigabit speed is
important to me.  Another user has experienced the same problem after

The card in question is an Intel Corporation 82541PI Gigabit Ethernet
Controller.  I've tried the usual: changing cables, restarting,
ethtool -- nothing is working to get it up to speed.  Details of my
setup are at the bottom ...

I guess my question is, should I file this as a bug ?  And, if yes,
what info do I need to include beyond what is already here ?  The help
documentation says I should use apport-cli but I am not sure how to
identify this card/driver as the problem


sudo lshw -C network
       description: Ethernet interface
       product: 82541PI Gigabit Ethernet Controller
       vendor: Intel Corporation
       physical id: e
       bus info: pci at 0000:00:0e.0
       logical name: eth0
       version: 05
       serial: 00:0e:0c:d9:ca:1f
       size: 100MB/s
       capacity: 1GB/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm pcix bus_master cap_list ethernet physical tp
10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000
driverversion=7.3.20-k2-NAPI duplex=full firmware=N/A ip=
latency=64 link=yes mingnt=255 module=e1000 multicast=yes port=twisted
pair speed=100MB/s

Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	Advertised auto-negotiation: Yes
	Speed: 100Mb/s
	Duplex: Full
	Port: Twisted Pair
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: umbg
	Wake-on: g
	Current message level: 0x00000007 (7)
	Link detected: yes

More information about the Ubuntu-bugsquad mailing list