[Ubuntu-BR] Instalação Google Chrome - dependencia não é compatível

Humberto Fraga xisberto em gmail.com
Segunda Outubro 21 19:09:53 UTC 2013


Luiz, não saia executando qualquer comando sem saber o que significa, muito
menos sem ler com atenção as mensagens de erro.

Você executou comandos que retornaram erro, e estes erros impediram que os
comandos seguintes continuassem.

Em 21 de outubro de 2013 14:59, Lulinha <luizescampello em gmail.com> escreveu:

> Olá!
>
> Segui um tutorial que está nesse site "
>
> http://tutorfreebr.blogspot.com.br/2012/03/instalar-chromechromium-via-terminal-no.html
> ",
> mas não tive sucesso. Segue abaixo o resultado:
>
>
Este tutorial tem mais de um ano de idade! Isso pode ser a causa dos
problemas!!!


> campello em campello-Aspire-4740:~$ sudo apt-get install libxss1 libcurl3
> libnspr4 libnss3-1d
> [sudo] password for campello:
> Lendo listas de pacotes... Pronto
> Construindo árvore de dependências
> Lendo informação de estado... Pronto
> libxss1 já é a versão mais nova.
> libcurl3 já é a versão mais nova.
> libnspr4 já é a versão mais nova.
> libnss3-1d já é a versão mais nova.
> Os seguintes pacotes foram instalados automaticamente e já não são
> necessários:
>   thunderbird-globalmenu linux-headers-3.2.0-54
>   linux-headers-3.2.0-54-generic-pae
> Use 'apt-get autoremove' para removê-los.
> 0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0
> não atualizados.
>

Até aqui, nada de mais, apenas que os pacotes já estão instalados.


> campello em campello-Aspire-4740:~$ wget -q -O -
> https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add
> gpg: impossível abrir `': Arquivo ou diretório não encontrado
>

Aqui ocorre o primeiro erro. Por algum motivo, o download falhou, e seria
interessante saber o motivo. Mas acho que isso se tornaria irrelevante se
você ignorar o tutorial.


> campello em campello-Aspire-4740:~$ sudo sh -c 'echo "deb
> http://dl.google.com/linux/chrome/deb/ stable main" >>
> /etc/apt/sources.list.d/google.list'
>

Aqui você está adicionando esse repositório do Google à sua instalação.
Repare que se você instalar o Chrome baixado no site dele, ele será
adicionado sem que você precise fazer isso.


> campello em campello-Aspire-4740:~$ sudo apt-get update
> Atingido http://br.archive.ubuntu.com precise Release.gpg
> Atingido http://br.archive.ubuntu.com precise-updates
>

[removendo linhas extras]


> Atingido http://security.ubuntu.com precise-security/universe
> Translation-en
> Baixados 621 kB em 4s (138 kB/s)
> Lendo listas de pacotes... Pronto
> W: Erro GPG: http://dl.google.com stable Release: As assinaturas a seguir
> não puderam ser verificadas devido à chave pública não estar disponível:
> NO_PUBKEY A040830F7FAC5991
> W: Duplicate sources.list entry
> http://dl.google.com/linux/chrome/deb/stable/main i386 Packages
>
> (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
>

Aqui ele informa duas coisas:
1. O repositório do Google está configurado mais de uma vez no seu apt, é
necessário remover.
2. Ele não verificou a assinatura do repositório, e isso se deve ao erro
que aconteceu lá em cima.

Com esses dois erros, o seu apt não atualiza a informação sobre que pacote
do Chrome baixar, e nem quais são as dependências dele, portanto ele tenta
instalar pacotes que não estão disponíveis para a sua versão do Ubuntu.



> campello em campello-Aspire-4740:~$ sudo apt-get install google-chrome-stable
> Lendo listas de pacotes... Pronto
> Construindo árvore de dependências
> Lendo informação de estado... Pronto
> Alguns pacotes não puderam ser instalados. Isto pode significar que
> você solicitou uma situação impossível ou, se você está usando a
> distribuição instável, que alguns pacotes requeridos não foram
> criados ainda ou foram retirados da "Incoming".
> A informação a seguir pode ajudar a resolver a situação:
>
> Os pacotes a seguir têm dependências desencontradas:
>  google-chrome-stable : Depende: lib32gcc1 (>= 1:4.1.1) mas não é
> instalável
>                         Depende: lib32stdc++6 (>= 4.6) mas não é instalável
>                         Depende: libc6-i386 (>= 2.11) mas não é instalável
> E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
>
>
Aqui ele tenta instalar os pacotes que não estão disponíveis.

O que você precisa fazer é o seguinte:

Organize suas listas do apt:
1. O arquivo /etc/apt/sources.list
2. Os arquivos dentro do diretório /etc/apt/sources.list.d
Remova as entradas duplicadas, mas provavelmente apenas a do Google está
duplicada.
Remova TODAS as entradas referentes ao Google.

Vá em http://www.google.com/intl/pt-BR/chrome/ e baixe o Chrome correto
para o seu Ubuntu. Será o pacote deb 32 ou 64 bits, dependendo da sua
instalação.

Instale com um clique duplo e depois clicando em instalar na tela que
aparecer ou com os comandos abaixo:

sudo dpkg -i pacote-do-chrome.deb
sudo apt-get -f install

Espero que tenha sido claro, e que você consiga resolver o problema.

-- 
Humberto Fraga
https://play.google.com/store/apps/developer?id=Humberto+Fraga



More information about the ubuntu-br mailing list