[Ubuntu-BR] Instalando o Firefox 24 e travando sua atrualização

luciano de souza luchyanus em gmail.com
Sábado Novembro 23 12:45:33 UTC 2013


Parece que deu certo, pois após duas reiniciações do Firefox, ele
permanece na versão 24.0.

O comando foi o seguinte:


sudo apt-get purge firefox && sudo apt-get install
firefox=24.0+build1-0ubuntu1 && sudo apt-mark hold firefox && firefox
--safe-mode

Iniciei a primeira vez no modo seguro para impedir que ele se atualizasse só.

A resposta a "which firefox" é "/usr/bin/firefox".

Fiquei com o Firefox em inglês, mas a esta altura, nem vou pensar em
atualizar o idioma!

A equipe de desenvolvimento do Firefox já foi contatada pela equipe de
desenvolvimento do Orca, uma vez que o erro, segundo parece, é no
navegador e não no leitor de telas, então, se tudo der certo, não devo
ficar com o Firefox desatualizado por muito tempo.

De qualquer modo, a coisa foi um tanto confusa no "about:config". Eu
encontrei facilmente a chave "app.update.auto" e verifiquei que ela
estava assinalada para  "true".

O problema era: como mudá-la para "false"? Não posso utilizar o mouse
porque sou cego e não conseguia mudar o estado com a barra de espaços,
o que é o usual.

Ao fim, com o menu de contexto, encontrei uma opção "new", com submenu
"toogle", escolhi tal opção e parece que tive êxito.

No entanto, a chave app.update.auto desapareceu, o que provavelmente
significa que, quando for necessário atualizar o Firefox para a futura
e corrigida versão 25, terei de reinstalar os pacotes do 0.

Bom, se não atualizar mais, este é mal muitíssimo menor.

De qualquer modo, estava a aconselhar outros colegas cegos sobre como
evitar a tal atualização. Cheguei a enviar-lhes uma mensagem quando
pensei ter conseguido. Agora, já não sei o que dizer. Aconselho que
também apaguem a sua chave app.update.auto? Não parece tecnicamente
muito adequado!

Em 23/11/13, Humberto Fraga<xisberto em gmail.com> escreveu:
> Luciano, neste caso você precisa ter certeza de que está usando o Firefox
> instalado pelo apt, e não outro Firefox instalado manualmente.
>
> Quando o Firefox está instalado pelo apt, ele não consegue se atualizar
> sozinho (precisaria de sudo para isso).
>
> Uma forma de verificar é usar o comando "which", que indica qual arquivo
> será chamado por um comando. Exemplo:
>
> which firefox deve retornar algo parecido com /usr/bin/firefox. Se retornar
> algum outro caminho, então você está executando um firefox instalado por
> fora do apt.
> On Nov 23, 2013 3:11 AM, "luciano de souza" <luchyanus em gmail.com> wrote:
>
>> O pior é que não me atentei para um fato aqui alertado. Sim, os
>> comandos do "apt" funcionaram perfeitamente. No entanto, na primeira
>> reiniciada do Firefox, ele atualizou para a versão que não poderia
>> atualizar. O resultado é que continuo a ter os problemas com o leitor
>> de telas.
>>
>> Agora, está claro como voltar a uma versão anterior, mas como impedir
>> que o Firefox burle o "apt-mark hold"? Infelizmente, a recomendação
>> somente valia para um "apt-get update", entretanto, se não é o apt a
>> atualizar, então, o "hold" de nada serve.
>>
>> Deve haver algum modo de evitar que o Firefox proceda deste modo,
>> afinal, seria um tantinho de autoritarismo demais!
>>
>> Pode ser que tenha procurado mal, mas no menu "editar",
>> "preferências", não encontrei nada a este respeito. De qualquer modo,
>> teria de encontrar um meio de entrar no Firefox sem que as
>> atualizações fossem disparadas imediatamente, pois, do contrário,
>> quando tivesse de chegar a qualquer menu, o trabalho já estaria feito.
>>
>> Em 22/11/13, Robson Dantas de Aguiar<meulinux em yahoo.com.br> escreveu:
>> > E o melhor é que eu aprendi mais uma no Linux.
>> >
>> > Valeu Humberto.
>> >
>> > Em 22-11-2013 18:48, luciano de souza escreveu:
>> >> Deu tudo certíssimo:
>> >>
>> >> $ sudo apt-cache madison firefox
>> >> $ sudo apt-get purge firefox
>> >> $ sudo apt-get install firefox=24.0+build1-0ubuntu1
>> >> $ sudo apt-mark hold firefox
>> >>
>> >> "Firefox marcado para manter". Tudo a funcionar como um relógio. Não
>> >> podia querer coisa melhor.
>> >>
>> >> Obrigado!
>> >>
>> >>
>> >> Em 21/11/13, luciano de souza<luchyanus em gmail.com> escreveu:
>> >>> Caros,
>> >>>
>> >>> Com um "sudo apt-get update", atualizou-se tudo.
>> >>>
>> >>> O problema é que convinha-me um pouco menos do que o "tudo". O
>> >>> Firefox
>> >>> 25 apresenta certas incompatibilidades com o leitor de telas, o orca
>> >>> 3.9.92.
>> >>>
>> >>> Então, queria instalar o Firefox 24. O primeiro passo é simples:
>> >>> "sudo
>> >>> apt-get purge firefox". Entretanto, uma vez que o tenha removido, não
>> >>> sei como instalar o Firefox da versão correta.
>> >>>
>> >>> Mais do que isso. Não sei como impedir que o atrevido do "apt-get"
>> >>> ignore, para todo o sempre, as atualizações do Firefox, deixando-me
>> >>> tranquilo a utilizar a versão comprovadamente acessível.
>> >>>
>> >>> Teriam alguma ideia sobre como fazer aquilo que desejo?
>> >>>
>> >>> --
>> >>> Luciano de Souza
>> >>>
>> >>
>> >
>> >
>> > --
>> > Mais sobre o Ubuntu em português: http://www.ubuntu-br.org/comece
>> >
>> > Lista de discussão Ubuntu Brasil
>> > Histórico, descadastramento e outras opções:
>> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-br
>> >
>>
>>
>> --
>> Luciano de Souza
>>
>> --
>> Mais sobre o Ubuntu em português: http://www.ubuntu-br.org/comece
>>
>> Lista de discussão Ubuntu Brasil
>> Histórico, descadastramento e outras opções:
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-br
>>
> --
> Mais sobre o Ubuntu em português: http://www.ubuntu-br.org/comece
>
> Lista de discussão Ubuntu Brasil
> Histórico, descadastramento e outras opções:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-br
>


-- 
Luciano de Souza




More information about the ubuntu-br mailing list