[Ubuntu-BR] RES: Não posso instalar o PHP 5.3.2 por causa de um erro na LIBXML2

Fernando Correa da Conceição conceicao.fernando em gmail.com
Terça Março 9 23:47:18 UTC 2010


Em 9/3/2010 17:49, Héberson Sette de Almeida escreveu:
> Rafael
> Acredito que esteja instalo o pacote libxml2.
>
> Veja o resultado do aptitude search libxml2.
>
> i   libxml2                                                                -
> GNOME XML library
> p   libxml2-dbg                                                            -
> Debugging symbols for the GNOME XML library
> p   libxml2-dev                                                            -
> Development files for the GNOME XML library
> p   libxml2-doc                                                            -
> Documentation for the GNOME XML library
> p   libxml2-utils                                                          -
> XML utilities
> p   python-libxml2                                                         -
> Python bindings for the GNOME XML library
> p   python-libxml2-dbg                                                     -
> Python bindings for the GNOME XML library (debug extension)
> v   python2.5-libxml2                                                      -
> v   python2.6-libxml2
>
> Sugere algo?
>
>    
Sempre que você tiver um problema com um pacote nesse tipo de questão de 
compilar, instala o pacote dev ou devel, neste caso instala a libxml-dev


Fernando.
> Héberson Sette de Almeida
>
>
>
>
>
>
> -----Mensagem original-----
> De: ubuntu-br-bounces em lists.ubuntu.com
> [mailto:ubuntu-br-bounces em lists.ubuntu.com] Em nome de Rafael Moraes
> Enviada em: terça-feira, 9 de março de 2010 17:34
> Para: Lista de discussão do LoCoTeam Brasileiro
> Assunto: Re: [Ubuntu-BR] Não posso instalar o PHP 5.3.2 por causa de um erro
> na LIBXML2
>
> Boa tarde amigo
> dá um aptitude search libxml2
>
> senao aparecer, da um aptitude update
>
> abraço
>
> Em 9 de março de 2010 16:52, Héberson Sette de Almeida<
> heberson.sette em gmail.com>  escreveu:
>
>    
>> Olá a Todos!
>>
>> Acabei de Instalar o Ubuntu 9.10 Server 32 Bit com o  Apache 2.2.14.
>>
>> Agora estou tentando instalar o PHP 5.3.2, mas quando tento instalar como
>> root a seguinte mensagem aparece e a instalação do PHP sai sem terminar.
>>
>> Configuring extensions
>> checking size of long... (cached) 4
>> checking size of int... (cached) 4
>> checking for int32_t... yes
>> checking for uint32_t... yes
>> checking for sys/types.h... (cached) yes
>> checking for inttypes.h... (cached) yes
>> checking for stdint.h... (cached) yes
>> checking for string.h... (cached) yes
>> checking for stdlib.h... (cached) yes
>> checking for strtoll... yes
>> checking for atoll... yes
>> checking for strftime... (cached) yes
>> checking which regex library to use... php
>> checking whether to enable LIBXML support... yes
>> checking libxml2 install dir... no
>> checking for xml2-config path...
>> configure: error: xml2-config not found. Please check your libxml2
>> installation.
>>
>> But If I try to install libxml2 the apt-get utility from UBUNTU tells me:
>>
>> heberson em rsttiubtu:/tmp/php-5.3.2$ sudo apt-get install libxml2
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> libxml2 is already the newest version.
>> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>>
>> Alguém sabe como resolver isto para que eu possa instalar o PHP 5.3.2
>>
>> Qualquer ajuda será apreciada.
>>
>>
>> Héberson Sette de Almeida
>>
>>
>> Nenhum vírus encontrado nessa mensagem enviada.
>> Verificado por AVG - www.avgbrasil.com.br
>> Versão: 9.0.790 / Banco de dados de vírus: 271.1.1/2732 - Data de
>> Lançamento: 03/09/10 04:33:00
>>
>>
>> --
>> Mais sobre o Ubuntu em português: http://www.ubuntu-br.org/comece
>>
>> Lista de discussão Ubuntu Brasil
>> Histórico, descadastramento e outras opções:
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-br
>>
>>      
>
>
>    





More information about the ubuntu-br mailing list