[Ubuntu-BR] ATi fglrx 8.42.3

Marcus VBP falecomigo em marcusvbp.com.br
Quinta Outubro 25 01:25:37 UTC 2007


rapaz, eu instalei o driver novo, ele funcionou. to com o compiz ativado e
tudo, sem o xserver-xgl... os jogos do cedega funcionaram (antes, nenhum
abria), apesar de que um deles ficou lento.

Só que eu tenho notado uma certa lentidão, eu to achando o sistema mais
lento pra responder graficamente... a rolagem do firefox tá devagar. quando
eu faço algum uso do compiz, como rodar o cubo ou mover as janelas
rapidamente, noto uma linha diagonal que "quebra" a imagem. é difícil de
explicar.

alguém mais teve este problema e/ou sabe como resolver?

minha placa de vídeo:
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon X1200 Series


Em 24/10/07, Khristian <der.kosak em gmail.com> escreveu:
>
> Não, o tutorial dessa página é para versões anteriores do driver. O
> novo não usa XGL e tem a extensão composite habilitada. E já é a
> segunda vez que eu digo a mesma coisa hoje.
>
> > Date: Wed, 24 Oct 2007 16:37:13 -0700 (PDT)
> > From: Eduardo Matias <sismiko em yahoo.com>
> > Subject: Re: [Ubuntu-BR] ATi fglrx 8.42.3
> > To: Lista de "discussão" do LoCoTeam Brasileiro
> >         <ubuntu-br em lists.ubuntu.com>
> > Message-ID: <361408.27882.qm em web52108.mail.re2.yahoo.com>
> > Content-Type: text/plain; charset=iso-8859-1
> >
> > Basicamente é o que está escrito nesta url :
> >
> >
> http://wiki.cchtml.com/index.php/Ubuntu_Feisty_Installation_Guide#Enable_.22restricted.22_Repository
> >
> >
> >
> > Antonio <alsampaio em gmail.com> wrote: Consegui fazê-lo funcionar, depois
> de muito penar. O problema era um pequeno
> > conflito que os pacotes davam com a versão já instalada. Descrevo aqui o
> > procedimento que utilizei:
> >
> > 1) Remover XGL
> > sudo apt-get remove xserver-xgl
> >
> > 2) Remover driver anterior (se presente)
> > sudo apt-get remove xorg-driver-fglrx
> >
> > 3) Deletar .debs de eventuais instalações antigas
> > sudo rm -f /usr/src/fglrx-kernel*.deb
> >
> > 4) Colocar driver dos repositórios na lista negra
> > sudo gedit /etc/default/linux-restricted-modules-common
> > e alterar (por exemplo) DISABLED_MODULES="" para
> DISABLED_MODULES="fglrx"
> >
> > 5) Criar uma nova pasta e copiar o programa de instalação
> > mkdir ~/ati
> > cd ~/ati
> > wget
> >
> http://www2.ati.com/drivers/linux/ati-driver-installer-8.42.3-x86.x86_64.run
> >
> > 6) Instalar pacotes necessários
> > sudo apt-get install module-assistant build-essential fakeroot dh-make
> > debhelper debconf libstdc++5 linux-headers-generic
> >
> > 7) Criar .debs
> > ./ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Ubuntu/gutsy
> >
> > 8) Instalar pacotes
> > sudo dpkg -i *.deb
> > (e, novamente)
> > sudo apt-get -f install
> >  ou
> > sudo dpkg -i *.deb
> >
> > 8) Compilar módulo do kernel
> > sudo m-a prepare,update
> > sudo m-a build,install fglrx-kernel
> > sudo depmod
> >
> > 9) Editar /etc/X11/xorg.conf para:
> > Section "Device"
> >     (...)
> >     Driver        "fglrx"
> >     (...)
> > EndSection
> >
> > e
> >
> > Section "Extensions"
> >     Option        "Composite"    "1"
> > EndSection
> >
> > 10) Reiniciar o computador
> > ou
> > sudo /etc/init.d/gdm stop
> > (e, então no modo texto)
> > sudo rmmod fglrx
> > sudo modprobe fglrx
> > sudo /etc/init.d/gdm start
> >
> > 11) Para permitir o uso do compiz, edite /etc/xdg/compiz/compiz-manager
> e
> > acrescente:
> > WHITELIST="nvidia intel ati radeon i810 fglrx"
> >
> > ---
> >
> > As mudanças no driver novo estão interessantes, mas ainda não ideais. O
> > suporte a AiGLX ainda está um tanto precário, além de ainda existirem
> alguns
> > bugs. Creio que os usuários de placas ATi só desfrutarão realmente de
> uma
> > boa experiência no Linux quando existir um driver livre e maduro.
> >
> > Boa sorte aos que tentarem.
> >
> > -Antonio
> >
> > On 10/23/07, Antonio  wrote:
> > >
> > > Como talvez muitos já saibam, a ATi lançou a tão esperada versão 8.42de
> > > seu driver proprietário. Dentre suas novidades está o suporte a AIGLX.
> > >
> > > Tentei instalar o driver novo, porém sem sucesso. Segui o procedimento
> de:
> > > http://wiki.cchtml.com/index.php/Ubuntu_Gutsy_Installation_Guide
> > >
> > > Alguém obteve algum sucesso na instalação do driver e no uso de DRI?
> > >
> > > -Antonio
> > >
> > --
> > Interessado em aprender mais sobre o Ubuntu em português?
> > http://wiki.ubuntu-br.org/ComeceAqui  -
> > ubuntu-br mailing list
> > ubuntu-br em lists.ubuntu.com
> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-br
> >
> >
> >  __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam protection around
> > http://mail.yahoo.com
> >
> --
> Khristian Alexander Schönrock
> http://agilizando.blogspot.com - Notícias Quentinhas de Tecnologia!
> http://derkosak.blogspot.com - Meu blógue!
> --
> Interessado em aprender mais sobre o Ubuntu em português?
> http://wiki.ubuntu-br.org/ComeceAqui  -
> ubuntu-br mailing list
> ubuntu-br em lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-br
>



-- 
[]'s
Marcus VBP
http://www.marcusvbp.com.br



More information about the ubuntu-br mailing list