[Bug 405294] Re: a2dp skips terribly

Paul Brannan curlypaul924 at gmail.com
Tue Aug 17 02:57:39 BST 2010


Ok, I'm not positive if I'm experiencing the same bug, so please let me
know if I should enter a separate report.  Here's what I notice:

* Running Lucid on a Samsung NC10 netbook

* When I turn on my Jabra Extreme bluetooth headset, it connects to both
A2DP and telephony HSP/HFP.  I tried disabling HSP/HFP per a suggestion
in another bug report, but this kept me from connecting to A2DP as well.

* After the headset is connected, I immediately start seeing messages like this in /var/log/messages:
Aug 16 21:40:35 sapphire pulseaudio[2458]: module-bluetooth-device.c: Skipping 1934197 us (= 341192 bytes) in audio stream
Aug 16 21:40:38 sapphire pulseaudio[2458]: module-bluetooth-device.c: Skipping 2395199 us (= 422512 bytes) in audio stream

* The above messages come out every 20 seconds even though no audio is
playing.

* The messages continue to come out every 20 seconds in pairs 3 seconds apart until they get rate limited:
Aug 16 21:32:29 sapphire pulseaudio[2458]: ratelimit.c: 35 events suppressed

* In dmesg, I see this:
[  445.320774] l2cap_recv_acldata: Unexpected continuation frame (len 0)

* Audio is choppy and mplayer struggles to keep the audio and video in
sync

* If I try kzin's suggestion of:
$ sudo hciconfig hci0 lm master; sudo hciconfig hci0 lp hold,sniff,park
then video is much less choppy, but every 20 minutes or so I get skips.  It then takes a few minutes for audio and video to sync in mplayer.  This is using the -autosync option, otherwise the audio is perpetually out of sync.

* The wireless network also often (but not always) slows down.  I see the following messages in /var/log/messages:
Aug 16 21:12:17 sapphire kernel: [186631.588972] ath5k phy0: unsupported jumbo

* If I turn off my bluetooth headset, wireless speed returns to normal.

* Skipping audio is exacerbated by EM interference.  For example,
turning on an electric heater makes the audio skip terribly.  Turning
off the heater does not solve the problem, but it does make it better.
There may be other sources of interference in my house, but I have not
yet found them.

* There is no skipping if I try to watch a movie using HSP/HFP, but the
sound quality is only just bearable.

* I tried upgrading bluez to 4.0.69, but saw no improvement.

* I did not yet try upgrading pulseaudio.

* I did not yet try upgrading the kernel to see if the ath5k problem
will go away (another bug report suggested that the Maverick kernel
would fix this problem).

-- 
a2dp skips terribly
https://bugs.launchpad.net/bugs/405294
You received this bug notification because you are a member of
Bluetooth, which is subscribed to bluez in ubuntu.



More information about the Ubuntu-bluetooth mailing list