[Bug 474996] [NEW] bluetooth stops working after suspend

Launchpad Bug Tracker 474996 at bugs.launchpad.net
Thu Nov 5 18:27:37 GMT 2009

You have been subscribed to a public bug:

Bluetooth stops working after suspend to ram.  Under Jaunty everything
worked properly.

When working, lsmod | grep bt shows:
    btusb                  14260  4

..and the bluetooth applet appears on the panel, etc.  After resuming
from suspend, with or without toggling the bluetooth adapter (via key
combination, but apparently its built into the hardware), lsmod shows
"used by" of 0 instead of 4, the bluetooth applet disappears, the device
doesn't show up in lsusb anymore, and bluetooth-properties claims there
are no bluetooth adapters present.

After reboot it works normally again, including enabling and disabling
the adapter with the key combination.

Switching to a text console before pressing the key combination makes no
difference, nor does removing/reinserting btusb, or restarting
/etc/init.d/bluetooth (all of which have been tried both before and
after the key combination).

I'm not sure which package has the problem, so I've listed the versions
of several that seem potentially relevant below.

Software versions:
Ubuntu 9.10 upgraded from 9.04, amd64
bluez: 4.51-0ubuntu2
hal: 0.5.13-1ubuntu8
udev: 147~-6
kernel: 2.6.31-14-generic

system: Clevo M570TU laptop (a recent System76 Bonobo Professional)
BT device from lsusb:
    Bus 008 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

** Affects: bluez (Ubuntu)
     Importance: Undecided
         Status: New

bluetooth stops working after suspend
You received this bug notification because you are a member of Bluetooth, which is subscribed to bluez in ubuntu.

More information about the Ubuntu-bluetooth mailing list