[Bug 250677] [NEW] apple wireless keyboard and mighty mouse flaws when connecting to hardy heron

Launchpad Bug Tracker 250677 at bugs.launchpad.net
Wed Jul 23 20:00:51 BST 2008

You have been subscribed to a public bug by guyzmo (w-launchpad-m0g-net):


first, my system is :
 - AMD XP3200+ x2, with 2GB RAM, SATA hd and broadcom usb/bluetooth dongle.
 - Apple wireless keyboard (the old white plastic one) and apple wireless mighty mouse.

I have Ubuntu Hardy Heron updated to 8.04.1. It's originally a 6.06 install upgraded to every
7.* version until I upgraded it 2 monthes ago.

bluetooth kbd and mouse used to work perfectly after the slight modifications of config files.
following new howtos, I undoed everything I have modified.

but still, I have serious flaws I can't fix or even investigate on my own, I'm clueless and I'll appreciate
a little help. I can post config files and more logs if needed.

here are my flaws, it evolved as I tried to "fix" it. I asked for help
with no luck on IRC.

at the beginning, just after the update, I could peer and connect both keyboard and mouse. Though
a single click was doing multiple clicks (eg making it impossible to select a text in terminal) and a single
keypress was doing multiple keypresses (eg typing 'ls' would become 'llllllllllsssssssss'). When the keyboard
was connected, the mouse was behaving erroneously (ie not moving smoothly).

I tried apt-get remove --purge bluetooth bluetooth-gnome bluez*, and apt-get install it again, but no luck.
I tried changing options of xorg.conf (evdev, mouse, corepointer things...) but I noticed no change.

I let down for a while, too many work etc... and I played with xorg configuration for a while to try multiple display
setup. And I used the keyboard/mouse with my laptop all this time.

When retrying connecting both I had surprises. The mouse can't connect anymore, in bluetooth-applet it shows
"connected" (while the mouse's led is still blinking) and then it's disconnected again. I tryed to unpeer and peer it
again, but then it asked me a PIN, entered "0000" and it peered but still couldn't connect.

looking through the logs I got ''nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/bluetooth_acl_<mouse bt address>"
followed by nm_hal_device_removed(): ..." about ten seconds later.

and the mouse does not work anymore at all.

But the weirdest to the end :

when pairing the keyboard, it works, I can set a PIN and enter it in bluetooth-applet, but then when the keyboard 
finally connects (well I assume that's when), the computer freezes with capslock/scrolllock leds blinking. I have then
to reboot.

looking at the logs before the crash gives :

nm_device_added() : ... / nm_hal_device_removed() : ... , ink_key_request (sba=... ,dba=...) four times
then hcid writes : pin_code_request (sba=..., dba=...) and NetworkManager writes : added, removed, ink_key_request
pin_code and added/removed are done 4 times

and the last line in the log before syslogd restart is :

hcid: link_key_notify (sba=..., dba=...)

I really have to get this working, as my workaround for now is an old
crappy ps2 keyboard with mouse on numpad buttons...

thanks, in the hope of getting again the same user experience as I had
with feisty :-S

** Affects: ubuntu
     Importance: Undecided
         Status: New

** Tags: apple bluetooth freeze keyboard mightymouse
apple wireless keyboard and mighty mouse flaws when connecting to hardy heron
You received this bug notification because you are a member of Bluetooth, which is a direct subscriber.

More information about the Ubuntu-bluetooth mailing list