[Ubuntu-BD] Kubuntu Repo Signature problem

Shahriar Tariq shahriar at linux.org.bd
Sun Jan 25 09:45:58 GMT 2009


Hi,
The problem goes back for about a month..

The problem is resulting for a series of events so I think it might be
useful to know in details to provide solutions.

First I switched to Ubuntu Main Repo server  from Bangladesh Repo server
(since there is no real Repo server in Bangladesh)

at first it worked fine for about a week or two. then I started getting

"The following signatures were invalid: BADSIG 40976EAF437D05B5"
>

so I tried removing the signature and adding it back

(removed the signature using source list on adept)

then tried to export the key

$gpg -recv-keys 40976EAF437D05B5
> gpg: can't open `40976EAF437D05B5'
>


I tried switching to different Repo server and apt-get update...

currently my repo server is directed to tw.. http://debian.nctu.edu.twintrepid


I can update & install packages (but understandably getting no
authentication)


W: GPG error: http://debian.nctu.edu.tw intrepid Release: The following
> signatures couldn't be verified because the public key is not available:
> NO_PUBKEY 40976EAF437D05B5
>


any suggestions??


I wish google was more spot on the first time I was googling.. it did not
return any useful solutions.

today I found launchpad bug report on the same bad signature problem. there
are different solutions that worked for some while failed for others...
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/24061


any way can anyone help me add the signature back?


-- 
Thanking you
Shahriar

Volunteer, Bangladesh Linux Users Alliance http://linux.org.bd
http://forum.linux.org.bd

Marketing & Contents Officer, Ubuntu Bangladesh http://www.ubuntu-bd.org

Endorsement: আমাদের প্রযুক্তি ফোরাম http://forum.amaderprojukti.com/ and
মুক্ত.অর্গ http://mukto.org


More information about the ubuntu-bd mailing list