[Bug 1591490] [NEW] Please backport apt 1.0.9.2ubuntu2 from utopic (to fix do-release-upgrade)

danstowell 1591490 at bugs.launchpad.net
Sat Jun 11 11:09:45 UTC 2016


Public bug reported:

For me (and apparently many others), upgrading Ubuntu Trusty LTS to
Ubuntu Xenial LTS fails because do-release-upgrade bails out because of
apt error messages like this:


Unknown Multi-Arch type 'no' for package 'kwin'
Unknown Multi-Arch type 'no' for package 'kwin-dev'
Unknown Multi-Arch type 'no' for package 'kwin-wayland'
Unknown Multi-Arch type 'no' for package 'kwin-x11'
Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'

Unknown Multi-Arch type 'no' for package 'compiz-core'
Unknown Multi-Arch type 'no' for package 'compiz-gnome'
Unknown Multi-Arch type 'no' for package 'libxapian-dev'


It is caused by Debian bug #759099 [1] fixed in apt 1.0.7. Therefore I'm requesting a backport of "apt" to trusty.

In the title I've suggested 1.0.9 from utopic - a more recent version
might be fine too but when I tried to build the wily version on my local
machine it couldn't because the g++ requirement had moved on too far.


[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=759099

** Affects: trusty-backports
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to trusty-backports.
Matching subscriptions: ubuntu-backporters
https://bugs.launchpad.net/bugs/1591490

Title:
  Please backport apt 1.0.9.2ubuntu2 from utopic (to fix do-release-
  upgrade)

To manage notifications about this bug go to:
https://bugs.launchpad.net/trusty-backports/+bug/1591490/+subscriptions



More information about the ubuntu-backports mailing list