[Bug 1234612] Re: FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in Ubuntu 15.10 is 4 years old (v4.2.0)!

Mantas Kriaučiūnas mantas at akl.lt
Thu Sep 17 20:29:47 UTC 2015


** Summary changed:

- FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in Ubuntu 15.04 is 4 years old (v4.2.0)!
+ FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in Ubuntu 15.10 is 4 years old (v4.2.0)!

** Changed in: memtest86+ (Ubuntu)
       Status: Confirmed => Fix Committed

** Summary changed:

- FFe: Please merge memtest86+ 5.01-2 version from Debian - memtest86+ in Ubuntu 15.10 is 4 years old (v4.2.0)!
+ Please backport memtest86+ 5.01- version from Debian - memtest86+ in Ubuntu 14.04 LTS is 4 years old (v4.2.0)!

** Summary changed:

- Please backport memtest86+ 5.01- version from Debian - memtest86+ in Ubuntu 14.04 LTS is 4 years old (v4.2.0)!
+ Please backport memtest86+ 5.01-3ubuntu1 from Ubuntu 15.10 Wily to 14.04 LTS (memtest86 is 4 years old (v4.2.0) in LTS)!

** Also affects: trusty-backports
   Importance: Undecided
       Status: New

** Description changed:

  At September 2013, after more than 2 years since 4.20, 5.01 is finally
  out and the development of Memtest86+ is now fully resumed.
  
- Please merge memtest86+ 5.01-2 release from Debian - memtest86 4.2.0 in
- Ubuntu 15.04 beta is 4 years old and doesn't support lots of current
- hardware :(
+ Please backport memtest86+ 5.01-3ubuntu1 from Ubuntu 15.10 Wily to 14.04
+ LTS - memtest86+ is 4 years old in 14.04 LTS and doesn't support lots of
+ current hardware :(
  
  Bellow is debian/changelog entry:
+ 
+ memtest86+ (5.01-3ubuntu1) wily; urgency=medium
+   * Merge with Debian; remaining changes:
+     - Only run update-grub in the postrm on remove/purge.
+     - Drop the multiboot image from the GRUB menu for now, since it's
+       experimental and has known problems detecting all memory on some
+       systems at the moment.
+     - Do not update grub configuration, if running in container, or
+       update-grub not present, or grub config has not been previously
+       generated.
+     - Support localization of GRUB menu entries.
+     - Don't present the GRUB menu option on EFI systems, since it won't work.
+  -- Matthias Klose <doko at ubuntu.com>  Thu, 27 Aug 2015 14:44:32 +0200
+ 
+ memtest86+ (5.01-3) unstable; urgency=medium
+   * Build with -fgnu89-inline for GCC 5 (Matthias Klose, Closes: #778001)
+  -- Yann Dirson <dirson at debian.org>  Thu, 25 Jun 2015 19:14:21 +0200
  
  memtest86+ (5.01-2) unstable; urgency=medium
    * Build -O0 to workaround what is apparently a gcc 4.9 optimisation bug,
      and use "static" the __in and __out macros to allow compilation to
      proceed under this condition (as done in other distros, including
      Mageia, closes: #753627): memtest86+-5.01-O0.patch.
    * Fix PCI bus scanning on Nehalem architectures (patch from the Mageia
      package): memtest86+-5.01-array-size.patch.
    * Bumped Standards-Version to 3.9.5, no change.
   -- Yann Dirson <dirson at debian.org>  Wed, 10 Sep 2014 21:58:11 +0200
  
  memtest86+ (5.01-1) unstable; urgency=medium
    * Switch to source format 3.0 (quilt).
    * New upstream release (Closes: #727638).
      * Drop makeiso.sh fix for genisoimage, integrated upstream.
      * Refresh multiboot patch, but do not include additional fix for
        #568176 yet (needs more work).
      * Call build target explicitely, since the default target now attempts
        an scp.
    * Include chineses translations for package descriptions (Anthony Wong
      <ypwong at gmail.com>, Closes: #741432)
    * Only run update-grub in the postrm on remove/purge (Luke Faraone /
      Ubuntu, Closes: #587340)
    * Remove leading ./ in lintian-override paths so they get recognized again.
   -- Yann Dirson <dirson at debian.org>  Sat, 28 Jun 2014 17:02:10 +0200
  
  Memtest86+ V5.01 changelog from upstream:
  --------------------------
  - Added support for up to 2 TB of RAM on X64 CPUs
  - Added experimental SMT support up to 32 cores
  - Added complete detection for memory controllers.
  - Added Motherboard Manufacturer & Model reporting
  - Added CPU temperature reporting
  - Added enhanced Fail Safe Mode (Press F1 at startup)
  - Added support for Intel "Sandy Bridge-E" CPUs
  - Added support for Intel "Ivy Bridge" CPUs
  - Added preliminary support for Intel "Haswell" CPUs
  - Added preliminary support for Intel "Haswell-ULT" CPUs
  - Added support for AMD "Kabini" (K16) CPUs
  - Added support for AMD "Bulldozer" CPUs
  - Added support for AMD "Trinity" CPUs
  - Added support for AMD E-/C-/G-/Z- "Bobcat" CPUs
  - Added support for Intel Atom "Pineview" CPUs
  - Added support for Intel Atom "Cedar Trail" CPUs
  - Added SPD detection on most AMD Chipsets
  - Enforced Coreboot support
  - Optimized run time for faster memory error detection
  - Rewriten lots of memory timings detection code
  - Corrected bugs, bugs and more bugs
  
  Tips : F1 will enable fail-safe mode, F2 will enable SMP Mode (disabled
  by default) and F3 will trigger an hidden alternative SMP Mode.
  
  See http://memtest.org/#change for more info

-- 
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to trusty-backports.
Matching subscriptions: ubuntu-backporters
https://bugs.launchpad.net/bugs/1234612

Title:
  Please backport memtest86+ 5.01-3ubuntu1 from Ubuntu 15.10 Wily to
  14.04 LTS (memtest86 is 4 years old (v4.2.0) in LTS)!

To manage notifications about this bug go to:
https://bugs.launchpad.net/trusty-backports/+bug/1234612/+subscriptions



More information about the ubuntu-backports mailing list