[Bug 1505849] [NEW] Please backport golang 2:1.3.3-1ubuntu4 (universe) from vivid

Stéphane Graber stgraber at stgraber.org
Tue Oct 13 23:28:07 UTC 2015


Public bug reported:

Please backport golang 2:1.3.3-1ubuntu4 (universe) from vivid to trusty.

Alright, so that one needs some further explenation.

LXD unfortunately requires Go 1.3 or higher due to the 1.2 tls stack
lacking some features required for SSL client certificate
authentication.

We'd ideally want to update to Go 1.5 from wily for support reasons (as
vivid's 1.3 will go EOL in January) but we can't because unfortunately
Go 1.5 requires Go 1.4 to bootstrap itself.

So the best we can do for now is to backport vivid's current Go 1.3 to
trusty, use that to build LXD and then figure out a way to get us to 1.5
by January.
Achieving this will likely require using a temporary Go 1.4 package in a
devirt PPA to get us from 1.3 to 1.4 and then to 1.5, once we are at
1.5, we'd binary-copy the PPA content into backports.

Doing that part of the Go backport would I suspect require TB approval
or at least consensus from the backports team that it's sane and done in
a clean environment using only source packages that have been used in
the archive to do the same Go 1.5 bootstrap in wily.


I did confirm that 1.3 backports fine to trusty unmodified and that it
works as expected. This won't affect any existing package in the archive
since Go builds things statically and so will not affect any existing
built packages.

Only packages building inside trusty-backports would be building using
the new Go compiler and as we switched to Go 1.3 shortly after trusty,
anything which we would backport would be guaranteed to build using 1.3.


Reason for the backport:
========================

This is a requirement to be able to backport LXD to trusty.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s vivid -d trusty golang

* trusty:
[x] Package builds without modification
[x] golang-go-freebsd-amd64 installs cleanly and runs
[x] golang-go-freebsd-386 installs cleanly and runs
[x] golang-go-linux-amd64 installs cleanly and runs
[x] golang-go-darwin-386 installs cleanly and runs
[x] golang-go-linux-arm installs cleanly and runs
[x] golang installs cleanly and runs
[x] golang-src installs cleanly and runs
[x] vim-syntax-go installs cleanly and runs
[x] golang-mode installs cleanly and runs
[x] kate-syntax-go installs cleanly and runs
[x] golang-doc installs cleanly and runs
[x] golang-go-windows-386 installs cleanly and runs
[x] golang-go installs cleanly and runs
[x] golang-go-linux-386 installs cleanly and runs
[x] golang-go-windows-amd64 installs cleanly and runs
[x] golang-go-netbsd-amd64 installs cleanly and runs
[x] golang-go-netbsd-386 installs cleanly and runs
[x] golang-go-darwin-amd64 installs cleanly and runs
[x] golang-go-freebsd-arm installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of golang. For reverse-build-dependencies (-Indep), please test that the package still builds against the new golang. For reverse-dependencies, please test that the version of the package currently in the release still works with the new golang installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

golang-go-freebsd-amd64
-----------------------

golang-go-freebsd-386
---------------------

golang-go-linux-amd64
---------------------

golang-go-darwin-386
--------------------

golang-go-freebsd-arm
---------------------

golang-go-linux-arm
-------------------

golang
------
* golang-gocapability-dev
  [x] trusty (Reverse-Build-Depends)
* docker.io
  [x] trusty (Reverse-Build-Depends)

golang-src
----------

vim-syntax-go
-------------
* vim-gocomplete
  [x] trusty (Reverse-Depends)

kate-syntax-go
--------------

golang-mode
-----------

golang-go-windows-386
---------------------

golang-go
---------
* pollen
  [x] trusty (Reverse-Build-Depends)
* golang-godebiancontrol-dev
  [x] trusty (Reverse-Build-Depends)
* golang-dns
  [x] trusty (Reverse-Build-Depends)
* golang-goprotobuf
  [x] trusty (Reverse-Build-Depends)
* golang-gocheck
  [x] trusty (Reverse-Build-Depends)
* golang-pretty
  [x] trusty (Reverse-Build-Depends)
* usensord
  [x] trusty (Reverse-Build-Depends)
* golang-websocket
  [x] trusty (Reverse-Build-Depends)
* libguestfs
  [x] trusty (Reverse-Build-Depends)
* golang-go.tools
  [x] trusty (Reverse-Breaks)
  [x] trusty (Reverse-Replaces)
  [x] trusty (Reverse-Build-Depends)
* golang-termbox
  [x] trusty (Reverse-Build-Depends)
* golang-dns-dev
  [x] trusty (Reverse-Depends)
* golang-thrift
  [x] trusty (Reverse-Build-Depends)
* golang-libgeoip
  [x] trusty (Reverse-Build-Depends)
* hockeypuck
  [x] trusty (Reverse-Build-Depends)
* golang-doozer
  [x] trusty (Reverse-Build-Depends)
* golang-nzaat
  [x] trusty (Reverse-Build-Depends)
* codesearch
  [x] trusty (Reverse-Build-Depends)
* golang-go-dbus
  [x] trusty (Reverse-Build-Depends)
* gocode
  [x] trusty (Reverse-Build-Depends)
* golang-bindata
  [x] trusty (Reverse-Build-Depends)
* golang-text
  [x] trusty (Reverse-Build-Depends)
* golang-goyaml
  [x] trusty (Reverse-Build-Depends)
* golang-log4go
  [x] trusty (Reverse-Build-Depends)
* ubuntu-push
  [x] trusty (Reverse-Build-Depends)
* golang-pb
  [x] trusty (Reverse-Build-Depends)
* juju-core
  [x] trusty (Reverse-Build-Depends)
* golang-vhost
  [x] trusty (Reverse-Build-Depends)
* gccgo-go
  [x] trusty (Reverse-Conflicts)
* golang-go-xdg
  [x] trusty (Reverse-Build-Depends)
* goget-ubuntu-touch
  [x] trusty (Reverse-Build-Depends)
* golang-go-flags
  [x] trusty (Reverse-Build-Depends)
* golang-metrics
  [x] trusty (Reverse-Build-Depends)
* golang-openldap
  [x] trusty (Reverse-Build-Depends)
* ngrok
  [x] trusty (Reverse-Build-Depends)

golang-go-linux-386
-------------------

golang-go-windows-amd64
-----------------------

golang-go-netbsd-amd64
----------------------

golang-go-netbsd-386
--------------------

golang-go-darwin-amd64
----------------------

golang-doc
----------

** Affects: trusty-backports
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to trusty-backports.
Matching subscriptions: ubuntu-backporters
https://bugs.launchpad.net/bugs/1505849

Title:
  Please backport golang 2:1.3.3-1ubuntu4 (universe) from vivid

To manage notifications about this bug go to:
https://bugs.launchpad.net/trusty-backports/+bug/1505849/+subscriptions



More information about the ubuntu-backports mailing list