[Bug 1361340] [NEW] Please backport iucode-tool 1.0.3-1 (multiverse) from utopic

Philipp Kern phil+launchpad at philkern.de
Mon Aug 25 19:41:15 UTC 2014


Public bug reported:

Please backport iucode-tool 1.0.3-1 (multiverse) from utopic to precise,
trusty.

Reason for the backport:
========================
The intel-microcode package in precise is pretty simple and does not allow to
override microcode parts easily: it makes it hard to patch. Backporting
iucode-tool is the first step to fix that, as it makes microcode handling
much more pleasant.

I'm not that concerned about trusty but figured that given the tool wants it,
that it might be sensible. (It might also be fit for a stable update.) Plus
it is needed to ensure upgradability from precise to trusty if one
backports the utopic version instead of, say, the trusty version.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:pkern/testing -s utopic -d precise iucode-tool
$ backportpackage -u ppa:pkern/testing -s utopic -d trusty iucode-tool

* precise:
[x] Package builds without modification
[x] iucode-tool installs cleanly and runs
* trusty:
[x] Package builds without modification
[x] iucode-tool installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of iucode-tool. For reverse-build-dependencies (-Indep), please test that the package still builds against the new iucode-tool. For reverse-dependencies, please test that the version of the package currently in the release still works with the new iucode-tool installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

iucode-tool
-----------
* intel-microcode
  [x] trusty (Reverse-Depends)
  [x] trusty (Reverse-Build-Depends)
* microcode.ctl
  [x] trusty (Reverse-Depends)

** Affects: precise-backports
     Importance: Undecided
         Status: New

** Affects: trusty-backports
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1361340

Title:
  Please backport iucode-tool 1.0.3-1 (multiverse) from utopic

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1361340/+subscriptions



More information about the ubuntu-backports mailing list