[Bug 1153089] [NEW] Please backport config-package-dev 5.0 to lucid

Launchpad Bug Tracker 1153089 at bugs.launchpad.net
Sat Mar 9 23:46:49 UTC 2013


You have been subscribed to a public bug by Geoffrey Thomas (geofft):

This is a followup to #1153009, which synced config-package-dev 5.0 to
raring. (This bug report is mostly adapted from that one.)

config-package-dev is a set of extension modules for CDBS and Debhelper
(including a dh7 sequencer module) to allow site sysadmins to create
Debian packages for system configuration. It's extensively used by the
MIT Debathena project, where it originated, and used by a handful of
other sites.

I released config-package-dev 5.0 a few days ago (it's Debian-native),
which includes the Debhelper and dh7 support, and it was just synced to
raring. The previous versions of config-package-dev only support CDBS.

The CDBS module in config-package-dev 5.0 remains completely API-
compatible with 4.x, and furthermore, there are no packages in the
archive that build-depend on config-package-dev (since it's primarily
intended for use at a specific site to configure their OS, not by an
upstream distribution), so the regression potential is basically
nonexistent. I've tested the new version on everything in Debathena, to
be confident.

Backporting config-package-dev would allow us to encourage its use by
folks learning Debian packaging today, since dh7 is gaining popularity
over CDBS. I gave a lightning talk at UDS-Q about config-package-dev,
and the number one question I received is "When will it support dh7 and
not just CDBS?"

I've made sure that the package builds cleanly on all supported Ubuntu
releases from Lucid onwards, and tested it on Debathena's sbuild-based
build server and made sure that all of the test packages in examples/
build fine on all of these releases. If you're curious, these builds are
in http://debathena.mit.edu/apt in the debathena-system component of the
precise-development etc. pockets.

I primarily want backports for Lucid and Precise. I'm happy to have an
Oneiric backport also, but it's being desupported soon, so I don't
particularly care.

config-package-dev (5.0) unstable; urgency=low

  * Add Debhelper support (Debathena: #867) (Closes: #693672). This
    release includes a new command, dh_configpackage, and a sequencer
    extension, dh --with config-package.
  * Use the terms "displace" and "hide" for actions of the
    config-package-dev system, instead of the terms "divert" and
    "remove", which already have existing (related) meanings in the
    context of Debian packages.
  * Move examples/* to examples/cdbs/*, and create examples/debhelper/*,
    with the same packages using Debhelper 7-style packaging.

  * Change config-package-dev's own packaging to Debhelper 7.
  * Bump Standards-Version to 3.9.4 (no changes required).
  * Update Vcs-Git and Vcs-Browser locations to new upstream.
  * Drop CDBS runtime dependency. CDBS users should be explicitly
    Build-Depending on CDBS, probably through use of the @cdbs@ macro in
    debian/control.in.

 -- Geoffrey Thomas <geofft at mit.edu> Wed, 06 Mar 2013 17:14:42 -0800

** Affects: config-package-dev (Ubuntu)
     Importance: Undecided
         Status: New

-- 
Please backport config-package-dev 5.0 to lucid
https://bugs.launchpad.net/bugs/1153089
You received this bug notification because you are a member of Ubuntu Backporters, which is subscribed to the bug report.



More information about the ubuntu-backports mailing list