[Bug 384971] Re: Please backport sword 1.6+dfsg-1 from Karmic

Dmitrijs Ledkovs dmitrij.ledkov at gmail.com
Mon Jun 8 23:36:48 BST 2009

** Description changed:

  == Backport Request ==
  Please backport source package sword 1.6+dfsg-1 from Ubuntu karmic to hardy,
  intrepid and jaunty.
  1. Package is in karmic [0]
  2. No source modifications are required for all suites [4]
  3. Affects only it self
     1. compatible with system libraries on all suites.
     2. does not directly brake other packages on system.
     3. It *is* a soname bump.
     Output in karmic/pbuilder login
     # apt-cache rdepends libsword8
     Reverse Depends:
     Libsword-dev, libsword-dbg and diatheke are build from the sword source
-    package. I'm also requesting backport of xiphos and bibletime.()
+    package. I'm also requesting backport of xiphos and bibletime. (Bug #384978 Bug #384976)
     4. No changes to language interpreters.
  4. There are meaningful benefits to the users ~2 years of upstream feature
  development. There are no known security issues with neither old, nor new
  packages. It is library/API which is needed for new versions of xiphos and
  bibletime (which have hot new features). The actual sword library new features
  are listed in this changelog [5] (quite big see 1.5.10-1.6.0). Most importantly
  is UTF-8 support, better locale support, better tools to create Sword modules
  == History ==
  In January 2009 there was a call from upstream [1] to update the Crosswire
  related software in Ubuntu because it was more than 2 years old. These
  applications are sword library, gnomesword (later renamed to Xiphos) and
  bibletime. It is bible study software (library) with command-line, QT/KDE,
  GTK/Gnome front-ends.
  Shortly this got cross-posted to debian-devel. A debian maintainer was found,
  but he did not have enough time to commit to all of these packages. Instead a
  new Ubuntu/Debian team was formed [2,3].
  We did miss feature freeze for Jaunty, but now we have all of these packages in
  Debian Unstable and Ubuntu Karmic.
  To help testing and give users updated versions sooner we did stated to provide
  PPA[4]. Now it holds same packages as Unstable/Karmic. And we do have a few
  users using our PPA.
  Compatibility Lenny/Hardy - Unstable/Karmic has been kept for all the packages
  because one of our other goals was to backport all of these packages.
  == Links ==
  [0] http://packages.ubuntu.com/source/karmic/sword
  [1] https://lists.ubuntu.com/archives/ubuntu-motu/2009-January/005280.html
  [2] http://lists.alioth.debian.org/pipermail/pkg-crosswire-devel/
  [3] https://edge.launchpad.net/~pkgcrosswire
  [4] https://edge.launchpad.net/~pkgcrosswire/+archive/ppa
  [5] http://crosswire.org/ftpmirror/pub/sword/source/v1.6/sword-1.6.0/ChangeLog

Please backport sword 1.6+dfsg-1 from Karmic
You received this bug notification because you are a member of Ubuntu
Backports Testing Team, which is subscribed to Hardy Backports.

More information about the ubuntu-backports mailing list