[Bug 96454] Re: [Feisty, Gutsy] MASTER: HP LaserJet 1000/1005/1018/1020 don't work because of missing firmware

Till Kamppeter till.kamppeter at gmail.com
Thu Jan 22 09:53:14 GMT 2009


HP has provided a tool now to easily download the firmware for all their
printers which need a firmware file. So you need not to compile the
foo2zjs driver package or create a print queue with HP's hp-setup any
more.

If you have HPLIP 2.8.12 (on Jaunty) do:

sudo hp-plugin

and follow the instructions on the screen. This downloads and installs
the firmware files for all HP printers which need such a file. After
that it looks for existing print queues of such printers and uploads the
firmware files into them immediately. So you will be able to print from
all auto-generated queues for these printers immediately after the tool
has finished.

I plan to integrate the call of the tool into system-config-printer.

An additional hint: On a default installation of Jaunty you will perhaps
get presented a text mode interface in your terminal window. To get a
graphical interface, run

sudo apt-get install hplip-gui

before running hp-plugin. Note that this installs some MB of additional
packages.

-- 
[Feisty, Gutsy] MASTER: HP LaserJet 1000/1005/1018/1020 don't work because of missing firmware
https://bugs.launchpad.net/bugs/96454
You received this bug notification because you are a member of Ubuntu
Backports Testing Team, which is subscribed to Gutsy Backports.



More information about the ubuntu-backports mailing list