[Bug 315506] [NEW] Please backport puppet 0.24.5 or newer to hardy (LTS)

Jon Kjaersgaard jk05 at imada.sdu.dk
Fri Jan 9 15:37:33 GMT 2009

Public bug reported:

Puppet is a configuration managment tool. Hardy ships standart with puppet 0.24.4. 
However 0.24.4 has a major bug that renders it virtually useless. (https://bugs.launchpad.net/ubuntu/+source/puppet/+bug/176113)
The bug prevents the puppet daemon from ever starting in most cases, especially when running in an environment using dhcp.
Puppet starts, attempts to reach it's server, fails and never tries again... All before an IP has been received from the dhcp server.

The bug has been fixed upstream as of version 0.24.5.

As puppet is very use full in larger desktop deployments, it would be nice if a Long Term Support  version of ubuntu had a functioning version of puppet :) 
Especially as many who run a tool like puppet is also likely to run Long Term Support versions of ubuntu in order to avoid having to upgrade every six months

-- Jon

** Affects: hardy-backports
     Importance: Undecided
         Status: New

Please backport puppet 0.24.5 or newer to hardy (LTS)
You received this bug notification because you are a member of Ubuntu
Backports Testing Team, which is subscribed to Hardy Backports.

More information about the ubuntu-backports mailing list