[Bug 89792] LDFLAGS=-lstdc++ needed for PostGIS

Toshimi Minoura minoura at eecs.orst.edu
Mon Mar 5 03:28:32 GMT 2007


Public bug reported:

1. Download postgis-1.2.1.tar.gz from 
    http://postgis.refractions.net/download/
    to /usr/share/postgresql/8.1/contrib

2.  tar xvzf postgis-1.2.1.tar.gz
     cd postgis-1.2.1
      ./configure --prefix=/usr --with-pgsql=/usr/bin/pg_config --with-geos=/usr/bin/geos-config --with-proj=/usr
      make
      install
3. # create a PostgreSQL database for a test
     createdb zpostgis_test
     createlang plpgsql zpostgis_test
     psql -d zpostgis_test /usr/share/postgresql/8.1/contrib/postgis-1.2.1/wpostgis.sql

    We now get an error "Could not be loaded liblwgeom.so.1.2"
     even liblwgeom.so.1.2 is in /usr/lib.

** Affects: dapper-backports (upstream)
     Importance: Undecided
         Status: Unconfirmed

-- 
LDFLAGS=-lstdc++ needed for PostGIS 
https://launchpad.net/bugs/89792



More information about the ubuntu-backports mailing list