[Bug 120993] Re: Please backport libnetaddr-ip-perl 4.007 from Gutsy to Feisty

Scott Kitterman ubuntu at kitterman.com
Sat Jul 14 16:24:26 BST 2007


** Description changed:

  The new version of libnetaddr-ip-perl should be low risk for backporting
  as it's a small change, but it should bring substantial performance
- improvments for applications (such as Spamassassin) that use it:
+ improvments for applications (such as Spamassassin) that use it.  Since
+ Feisty it's been updated in Debian and synced.  The current Debian
+ changelog since the last common version are:
+ 
+ libnetaddr-ip-perl (4.007+dfsg-1) unstable; urgency=low
+ 
+   * Repackaged upstream sources without including the non-free RFC 1884
+     (Closes: #431090)
+   * Included README.Debian warning about requiring an API compatibility
+     mode when using with legacy (<3.21) code (taken straight from
+     Makefile.PL's output)
+ 
+  -- Gunnar Wolf <gwolf at debian.org>  Tue, 03 Jul 2007 10:45:18 -0500
+ 
+ libnetaddr-ip-perl (4.007-1) unstable; urgency=low
+ 
+   [ Julian Mehnle ]
+   * New upstream release (closes: #329644).
+   * Architecture: any (was: all), as this package now includes XS code.
+   * Standards-Version: 3.7.2
+   * Build-Depends: libtest-pod-perl
+   * Build-Depends: debhelper (was: Build-Depends-Indep:)
+   * Raised debhelper compatibility level to 5, adjusted Build-Depends.
+   * Updated debian/rules to latest dh-make-perl template.
+   * Run tests during package building.
+   * Generate perlapi and libc6 dependencies using dh_shlibdeps.
+   * Conflicts: libnetaddr-ip-lite-perl, as NetAddr::IP::Lite is now included
+     in this package.
+   * Updated package description.
+   * Updated debian/copyright with additional upstream author and new warranty
+     statement.
+   * Install all upstream README files and changelogs.
+   * Added debian/{compat,watch} files.
+   * Minor changes to NetAddr::IP{,::Lite} POD code to correctly represent the
+     author names in the generated man-pages.
+ 
+   [ Gunnar Wolf ]
+   * Hijacking module on behalf of the Debian Pkg-perl group (previous
+     maintainer MIA)
+ 
+  -- Gunnar Wolf <gwolf at debian.org>  Thu, 28 Jun 2007 11:28:58 -0500
+ 
+ Before it was synced, the last Ubuntu change for Gutsy was:
  
    libnetaddr-ip-perl (4.007-0ubuntu1) gutsy; urgency=low
  
    * New upstream release
      - Removed all $& and $` to increase performance
    * Changed maintainer to MOTU
  
   -- Scott Kitterman <scott at kitterman.com>   Wed, 13 Jun 2007 22:49:18
  -0700
+ 
+ 4.007-0ubuntu1 and 4.007-1 were virtually identical (derived from the
+ same set of draft packages), so despite the sync, the package heritage
+ is consistent.  This is a low risk backport.  Build, Installs, and Runs.
+ Tested with libmail-spf-perl (2.004-0ubuntu1).

** Changed in: feisty-backports (upstream)
   Importance: Undecided => Wishlist
       Status: New => In Progress

-- 
Please backport libnetaddr-ip-perl 4.007 from Gutsy to Feisty
https://bugs.launchpad.net/bugs/120993
You received this bug notification because you are a member of Ubuntu
Backporters, which is the registrant for Feisty Backports.



More information about the ubuntu-backports mailing list