[Bug 60823] Re: Please provide xlibs compatibility package

Fabio Massimo Di Nitto fabbione at ubuntu.com
Tue Oct 3 17:40:35 BST 2006


xorg (1:7.0.6) experimental; urgency=low

  * At the urgent request of the release and ftp teams, xlibs must die. Have
    the xserver-xorg package recommend xkb-data instead. xkb-data should
    already be pulled in by several pieces including the xorg metapackage,
    xutils, and xbase-clients

but the main reason is that since xlibs-static-dev and xlibs-dev are not there anylonger, there is very little point to carry around a xlibs.
Each package will need to B-D on the proper -dev and dh_shlibs will build the correct Depends: line for them.

while we can agree that installing all the xlibs is not that expensive
(size wise) other people would complain that for a 4KB x apps that only
requires libx11-6, they don't want to install 20MB of extra stuff
because of maintainer lazyness.

so it has been agreed to do it right and in full and kill the package.

Also to note that we don't have xlibs in dapper. Reintroducing it would
be just pointless when all the other packages are transitioning.

Fabio

-- 
Please provide xlibs compatibility package
https://launchpad.net/bugs/60823



More information about the ubuntu-backports mailing list