Acroread Update Error

daniel sobey dns_server at yahoo.com
Fri Apr 17 00:28:05 BST 2009


Hi simon,

It's a package level error not a file error. The package says i have these files and another package says i have these files, the package manager looks at both and sees that the same file is in both and does not know what one has the right version of the file so it is giving out that error.

This is from a package not in the main ubuntu repositories? you probably have this kind of problem because you have one or many repositories that both contain a package with the same name, you probably started with a version from repo1 which had the program split into sub packages and the sub packages are slightly different in another repo and one version contains this file and another version has things different.

You are basically in the debian equivelent of "rpm hell".

You probably need to go to ether aptitude or synaptic and try and resolve the versions yourself, perhaps you can choose a different version of this pakcage or a related package that all comes from the same repository that would not have this problem as they would be packaged to be compatable with eachother. the other way is to completely remove this package and related packages and then install them again but you still may have the same problems as you still have conflicting repositories.

hope this helps.
--- On Fri, 17/4/09, Simon Ives <simon at simonives.info> wrote:

From: Simon Ives <simon at simonives.info>
Subject: Acroread Update Error
To: ubuntu-au at lists.ubuntu.com
Received: Friday, 17 April, 2009, 7:55 AM

Hi all.
I'm having an issue updating the package acroread.  All other updates this week have functioned fine but when it comes to acroread I get the following error:
An error occurred

The following details are provided:
E: /var/cache/apt/archives/acroread_9.1.0-7intrepid1_i386.deb: trying to overwrite `/usr/share/man/man1/acroread.1.gz', which is also in package acroread-debian-files

I've changed the permissions on the file '/usr/share/man/man1/acroread.1.gz' and I still get the above error.  I've renamed the file and I still get the above error, which I think is weird as there is no file to overwrite.

I'm using intrepid on an Asus Eee PC 701SD and attempting to upgrade through the package manager's GUI.
Any ideas?

-- 
SIMON IVES
www.simonives.info

---------------------------------
Please consider the environment
before printing this email or any
attachments.



-----Inline Attachment Follows-----

-- 
ubuntu-au mailing list
ubuntu-au at lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-au
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-au/attachments/20090416/674f9d69/attachment.htm 


More information about the ubuntu-au mailing list