Domain won't connect

Cefiar cef at
Wed Oct 31 01:58:43 GMT 2007

On Wednesday 31 October 2007 11:53:51 Lisa wrote:
> She's got Gutsy on a system I built for her a few months ago, I don't
> actually think the problem is at her end though...
> Everything is working fine, except for one domain that she can't connect
> to. The domain resolves fine, so it's not a nameserver issue. She just can
> not get a connection to the server, she tried accessing the site by IP,
> still no connection... ping returns 100% packet loss... and wget just
> hangs when trying to connect, just like the browsers do.

Could be that she's been assigned an IP that is bogon filtered.

The below post (which is an internode forum FAQ, but references Optus), is 
informative on the problem.

On Optus, if you want to try and get a different IP (may or may not help 
with the above 
problem, depending on the IP you get), look at:

Other than that, you may find that TCP's Explicit Congestion Notification is 
turned on in the kernel, and that one of the routers in the path between you 
and the host breaks it.

To check if ECN is enabled, look the proc filesystem as below:

cat /proc/sys/net/ipv4/tcp_ecn

If you get 0, it's disabled. If it's 1, it's enabled. To disable, as root you 
can use:

echo 0 > /proc/sys/net/ipv4/tcp_ecn

If you want this permanent, use the sysctl tool (man sysctl), and add an entry 
into /etc/sysctl.conf as appropriate so it gets loaded on boot.

Note: I don't have Gutsy installed yet, so I can't tell you if the default 
behaviour of the kernel is different to feisty, but ECN is disabled on my 
feisty boxes by default (no tweaking on my part).

 Stuart Young - aka Cefiar - cef at

More information about the ubuntu-au mailing list