[Bug 436367] [NEW] Sync libcgicc 3.2.8-1 (universe) from Debian unstable (main)

Launchpad Bug Tracker 436367 at bugs.launchpad.net
Fri Sep 25 05:21:10 BST 2009

You have been subscribed to a public bug by fabrice_sp (fabricesp):

Hash: SHA1

 affects ubuntu/libcgicc
 status confirmed
 importance wishlist
 subscribe ubuntu-archive

Please sync libcgicc 3.2.8-1 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
ltmain.sh link is not anymore in support directory, and the build system uses
automatically the one from libtool package. So the change is not needed anymore.

Also, according to the upstream changelog, this is a bug fixing only release:
2009-01-18  Sebastien DIAZ  <sebastien.diaz at gmail.com>
        Corrected Bugs
        #25212 	'sort' undeclared
	#25211 	dns.cpp fails with memcpy undeclared
	#25073 	query string is incorrectly parsed, when post enctype is multipart/form-data 
	#24301 	CgiEnvironment constructor fails when posts have zero length
	#23979 	Swapped documentation blocks in CgiUtils.h

So no MOTU release ack needed.

It build fine, no soname bumd, and no rdepends, so I give my MOTU ack to this 
sync request.


Changelog entries since current karmic version 3.2.7-1ubuntu1:

libcgicc (3.2.8-1) unstable; urgency=low

  * New upstream version
    - Repacked upstream .orig.tar.gz after running 'make distclean' on it, as
      it contained a cygwin build. Merely cleaning this during the build caused
      dpkg-buildpackage to complain of unrepresentable changes to the source.

  * Updated to Standards-Version 3.8.2 (no changes required)
  * Updated debian/compat to 7, added comma after ${shlibs:Depends} in
  	debian/control. Replaced dh_clean -k with dh_prep, updated build-dep on
    debhelper to version 7. (fixes lintian warnings)
  * Add commands to debian/rules to re-libtoolize and autoreconf the package
    (closes: #527752)

 -- Chris Butler <chrisb at debian.org>  Thu, 03 Sep 2009 20:15:22 +0100

Version: GnuPG v1.4.9 (GNU/Linux)


** Affects: libcgicc (Ubuntu)
     Importance: Wishlist
         Status: Confirmed

Sync libcgicc 3.2.8-1 (universe) from Debian unstable (main)
You received this bug notification because you are a member of Ubuntu Package Archive Administrators, which is a direct subscriber.

More information about the ubuntu-archive mailing list