[Bug 339567] [NEW] Please sync extace 1.9.9-6 (universe) from Debian unstable (main)

Launchpad Bug Tracker 339567 at bugs.launchpad.net
Sun Mar 8 17:19:33 GMT 2009

You have been subscribed to a public bug by Nathan Handler (nhandler):

Binary package hint: extace

Debian has a new version which needs to be synced.

This sync makes 2 changes to the package. The first change is to update
the Build-Depends to use libfftw3-dev instead of fftw3-dev. This change
has already been applied in Ubuntu, and it is the reason that we have
had to merge this package in the past. The second change only modifies
one line of code:

--- extace-1.9.9.orig/src/input.c
+++ extace-1.9.9/src/input.c
@@ -67,7 +67,7 @@
                        /* esd rate is rate for each channel */
                update_ring_channels(2);  /* since ESD_STEREO is set */
-               handle.fd=esd_monitor_stream(ESD_BITS16|ESD_STEREO|ESD_STREAM|ESD_RECORD,ring_rate,"","eXtace");
+               handle.fd=esd_monitor_stream(ESD_BITS16|ESD_STEREO|ESD_STREAM|ESD_RECORD,ring_rate,NULL,"eXtace");
                if (handle.fd > 0) 
                        handle.open = 1;

This change has extace use the unix domain socket instead of a TCP
connection, which allows it to work properly with esd.

extace  (1.9.9-6) unstable; urgency=low

   * Use unix domain socket connection instead of TCP connection
     (Closes: #517446).

 -- Christian Marillat <marillat at debian.org>  Wed, 04 Mar 2009 14:36:06

extace (1.9.9-5) unstable; urgency=low

   * Change fftw3-dev by libfftw3-dev (new library name) in Build-Depends.
     (Closes: #463307)

 -- Christian Marillat <marillat at debian.org>  Mon, 16 Feb 2009 09:10:12

** Affects: extace (Ubuntu)
     Importance: Wishlist
         Status: Confirmed

** Tags: sync
Please sync extace 1.9.9-6 (universe) from Debian unstable (main)
You received this bug notification because you are a member of Ubuntu Package Archive Administrators, which is a direct subscriber.

More information about the ubuntu-archive mailing list