[Bug 400102] Re: Please sync libaqbanking 4.1.0-2 (universe) from Debian unstable (main).

Launchpad Bug Tracker 400102 at bugs.launchpad.net
Fri Jul 31 14:40:06 BST 2009

This bug was fixed in the package libaqbanking - 4.1.0-2ubuntu1

libaqbanking (4.1.0-2ubuntu1) karmic; urgency=low

  * Sync on debian (LP: #400102)
  * Applied a patch from gentoo to fix qbankmanger FTBFS with GCC 4.4

libaqbanking (4.1.0-2) unstable; urgency=low

  * Upload to Debian unstable.
  * Bump version in dependency on libgwenhywfar47-dev in package
    libaqbanking29-dev to match the version in build dependencies.

libaqbanking (4.1.0-1) experimental; urgency=low

  * New upstream release.
  * Build-dep on libgwenhywfar47-dev >= as required by ./configure.
  * Update symbols file. New symbols: AB_Banking_ExportToBuffer, AB_Gui_Extend,
    AB_Gui_Unextend, AB_Gui_new and AB_ImExporter_ExportToBuffer.
  * Package is compliant to Debian policy version 3.8.2 (no changes needed).

libaqbanking (4.0.0-2) experimental; urgency=low

  * Replace problematic symbols file for libqbanking8 by a simple shlibs

libaqbanking (4.0.0-1) experimental; urgency=low

  * New upstream release
  * Bump sonames and rename/update files accordingly:
    + libaqbanking28 -> libaqbanking29
    + libaqhbci15 -> libaqhbci16
    + libaqofxconnect4 -> libaqofxconnect5
    + libqbanking7 -> libqbanking8
  * debian/control:
    + Add binary package libaqbanking29-dbg containing debug symbols and
      tighten build-dep on debhelper >= 7.0.50 because of the new use of an
      override target for dh_strip in debian/rules
    + Relax libaqhbci16's dependency on libchipcard-libgwenhywfar47-plugins
      from a "Recommends:"- to a "Suggests:"-dependency to avoid libchipcard
      being installed on every Gnucash installation (closes: #491970)
    + Split (build) dependencies into multiple lines
  * debian/rules: Honour "nodocs" in DEB_BUILD_OPTIONS and skip generation of
    API documentation if it is present.

libaqbanking (3.99.13rc7-1) experimental; urgency=low

  * New upstream release
  * Add new binary aqbanking-cli to package aqbanking-tools.
  * Add magic keyword Build-Depends-Package to symbols files which
    were missing it (all except libaqbanking28.symbols).
  * Fix debian/changelog: upstream added missing #include for GCC 4.4
    in AqBanking 3.99.0beta, not before (see #525743 for details).

libaqbanking (3.99.11rc5-1) experimental; urgency=low

  * New upstream release
  * Add symbols files for libaqhbci15, libqbanking7 and libaqofxconnect4.
  * debian/control: Bump standards version (no changes needed).
  * Tweak debian/watch file to detect upstream release candidates too.

libaqbanking (3.99.10rc4-1) experimental; urgency=low

  * New upstream release
  * Remove ChangeLog from debian/*.docs files. They get installed by
    dh_installchangelogs and don't get compressed if installed
    additionally by dh_installdocs (see #515601 for discussion).
  * Bump versioned build-dep on libgwenhywfar47-dev for needed symbol
  * Drop transitional package aqbanking-tool. Lenny is released now.

libaqbanking (3.99.9rc3-1) experimental; urgency=low

  * New upstream release
    - adds missing #include for GCC 4.4 (closes: #504882)
  * Bump sonames: libaqbanking20 -> libaqbanking28, libaqhbci13 -> libaqhbci15,
    libqbanking6 -> libqbanking7 and rename files accordingly. Also several
    files have been changed to reflect this soname bump.

 -- Bhavani Shankar <right2bhavi at gmail.com>   Mon, 20 Jul 2009 11:53:08

** Changed in: libaqbanking (Ubuntu)
       Status: Incomplete => Fix Released

Please sync libaqbanking 4.1.0-2 (universe) from Debian unstable (main).
You received this bug notification because you are a member of Ubuntu
Package Archive Administrators, which is a direct subscriber.

More information about the ubuntu-archive mailing list