[Bug 399923] [NEW] Sync edje (universe) from Debian unstable (main).

Nicolas Valcárcel (nxvl) nicolas.valcarcel at canonical.com
Wed Jul 15 20:45:15 BST 2009

Public bug reported:

Hash: SHA256

 affects ubuntu
 status confirmed
 importance wishlist
 subscribe ubuntu-archive

Please sync edje (universe) from Debian unstable (main).

Changelog since current karmic version 0:

edje ( unstable; urgency=low

  * New upstream snapshot
  * Drop Add-libtool-Wl-as-needed-reordering-workaround.patch, no longer needed
  * Update libedje-bin deps following the evas engines rename
  * Upload to unstable

 -- Albin Tonnerre <albin.tonnerre at gmail.com>  Wed, 24 Jun 2009 22:23:39

edje ( experimental; urgency=low

  * New SVN snapshot
    - Drop patches, no longer needed:
      + 0002-fix-library-soname.patch
      + 0003-reapply-autofoo.patch
    - Package renaming due to upstream SONAME change.
      + Update shlibs and .install files as a consequence
  * Update Standards-Version, no change needed
  * Move libedje-dbg to the debug section
  * libedje-dev now depends on libedje-bin, as it's needed to compile themes
  * Package name purposedly doesn't match SONAME, in an attempt to make the
    former a bit more meaningful than libedje-ver-pre-01-0
    - Override the lintian warning: package-name-doesnt-match-sonames

 -- Albin Tonnerre <albin.tonnerre at gmail.com>  Thu, 07 May 2009 13:34:49

edje ( experimental; urgency=low

  * New SVN snapshot
   - tighten requirements on libeina-dev
   - Bump shlibs due to functions added to the API
   - Add --enable-doc to configure to get the doc built
   - Update dependency on libevas-engines
  * Make libedje-bin depend on a recent libembryo-bin
    - Fixes a bug when using edje_cc while E is running, as it calls embryo_cc,
      which uses environment variables set by E where it shouldn't
  * Use a proper short description for libedje-dbg

 -- Albin Tonnerre <albin.tonnerre at gmail.com>  Wed, 04 Feb 2009 00:48:09

edje ( experimental; urgency=low

  * Remove version name from -dev packages name
  * [lintian] Add ${misc:Depends} to libedje-doc too

 -- Albin Tonnerre <albin.tonnerre at gmail.com>  Tue, 06 Jan 2009 22:03:51

edje ( experimental; urgency=low

  * Upstream SVN snapshot
    - Packages renamed due to API changes
      + libedje-dev->libedje-, libedje0->libedje-
    - Add debian/patches/{01-fix-library-soname,02-reapply-autofoo}: Use release
      instead of version-info to create libedje SONAME, to prevent things
      from breaking when the ABI changes again.
    - Build-depend and make libedje- depend on libeina-0.0.1a-dev
  * [lintian] Add ${misc:Depends} to package dependencies
  * [lintian] Fix some escapes in debian/edje_cc.1 and debian/edje_recc.1
  * Update Standards-Version to 3.8.0

 -- Albin Tonnerre <albin.tonnerre at gmail.com>  Sat, 20 Dec 2008 21:18:58

edje ( experimental; urgency=low

  * Non-maintainer upload.
  * Fix FTBFS: Depend on suitable version of libevas-dev (Closes: #505235)

 -- Joachim Breitner <nomeata at debian.org>  Tue, 11 Nov 2008 00:54:03

edje ( experimental; urgency=low

  * New upstream release

 -- Jan Lübbe <jluebbe at debian.org>  Mon, 10 Nov 2008 00:48:39 +0100

edje ( experimental; urgency=low

  * New upstream release
  * Docs are now prebuilt in the tarball

 -- Jan Lübbe <jluebbe at debian.org>  Sun, 25 May 2008 18:59:51 +0200

edje ( experimental; urgency=low

  [ Jan Luebbe ]
  * Add support for keeping patches as git commits and build-depend on quilt
  * Add workaround for libtool option reordering
  * Enable -Wl,--as-needed

 -- Jan Lübbe <jluebbe at debian.org>  Sun, 04 May 2008 22:33:41 +0200

edje ( experimental; urgency=low

  * Initial Release (Closes: #468267)
  * Apply patch from Niv Sardi <xaiki at debian.org> and change it to
    document the license for data/* and doc/*. Also refer to
    common-licenses on Debian.

 -- Jan Lübbe <jluebbe at debian.org>  Wed, 19 Mar 2008 14:42:22 +0100

Version: GnuPG v2.0.9 (GNU/Linux)


** Affects: ubuntu
     Importance: Wishlist
         Status: Confirmed

Sync edje (universe) from Debian unstable (main).
You received this bug notification because you are a member of Ubuntu
Package Archive Administrators, which is a direct subscriber.

More information about the ubuntu-archive mailing list