[Bug 335137] [NEW] Please sync rolo 011.dfsg.1-14 (universe) from Debian unstable (main).

Launchpad Bug Tracker 335137 at bugs.launchpad.net
Thu Feb 26 21:21:10 GMT 2009


You have been subscribed to a public bug by Alessio Treglia (quadrispro):

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/rolo
 status confirmed
 importance wishlist
 subscribe ubuntu-archive

Please sync rolo 011.dfsg.1-14 (universe) from Debian unstable (main).

It contains only bugfixes, no FFe needed.

Changelog since current jaunty version 011.dfsg.1-10:

rolo (011.dfsg.1-14) unstable; urgency=low

  * debian/patches/compare-in-utf-8.diff: Add patch for ordering correctly
    the names in the index when they contain UTF-8 characters
  * debian/control: Build-depend on libunac1-dev, needed for the the
    patch above

 -- Rafael Laboissiere <rafael at debian.org>  Sat, 21 Feb 2009 19:18:36
+0100

rolo (011.dfsg.1-13) unstable; urgency=low

  * debian/patches/use-ncursesw.diff: Adjusted for providing the correct
    include flag in CFLAGS, such that the package really compiles against
    libncursesw5, avoiding FTBFS (closes: #515103)
  * debian/patches/utf8-in-index.diff: Adjusted for accepting UTF-8
    characters in email addresses (thanks to Carsten Hey for reporting the
    problem).
  * debian/patches/drop-libform.diff: Add patch for avoiding linking against
    libformw

 -- Rafael Laboissiere <rafael at debian.org>  Fri, 13 Feb 2009 18:22:28
+0100

rolo (011.dfsg.1-12) unstable; urgency=low

  * debian/patches/utf8-in-index.diff: Add patch for displaying columns
    correctly in the index screen when names are encoded in UTF-8
    (closes: #514933)
  * debian/control: Build-depend on libglib2.0-dev, since the patch above
    needs its function g_utf8_strlen

 -- Rafael Laboissiere <rafael at debian.org>  Fri, 13 Feb 2009 02:21:34
+0100

rolo (011.dfsg.1-11) experimental; urgency=low

  * debian/control:
    + Build-depend on libncursesw5-dev instead of libncurses5-dev, in order
      to support for wide character and corretly display entries in UTF-8
      (closes: #514926)
    + Fix Lintian warning debhelper-but-no-misc-depends
    + Build-depends on autoconf and automake
  * debian/patches/use-ncursesw.diff: New patch for forcing the use of
    libncursesw
  * debian/clean: Also remove config.status.lineno
  * debian/rules: Backup/restore files config.h.in and configure, which
    are changed during the build process

 -- Rafael Laboissiere <rafael at debian.org>  Thu, 12 Feb 2009 00:22:58
+0100


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkmnB6sACgkQRdSMfNz8P9BvEwCeNvw5favRI/ihl05F/FScwqa6
cQwAnjAWN+HvkYb9QyBYly8sYEvrq8B1
=gSFi
-----END PGP SIGNATURE-----

** Affects: rolo (Ubuntu)
     Importance: Wishlist
         Status: Confirmed

-- 
Please sync rolo 011.dfsg.1-14 (universe) from Debian unstable (main).
https://bugs.launchpad.net/bugs/335137
You received this bug notification because you are a member of Ubuntu Package Archive Administrators, which is a direct subscriber.



More information about the ubuntu-archive mailing list