[ubuntu-ar] k3b y paquetes rotos

Jorge Alvarez asjorgealvarez at gmail.com
Wed Nov 17 06:24:15 GMT 2010


El 17 de noviembre de 2010 02:55, Jorge Alvarez
<asjorgealvarez en gmail.com>escribió:

>
>
> El 16 de noviembre de 2010 15:30, Jorge Alvarez <asjorgealvarez en gmail.com>escribió:
>
>
>>
>> El 16 de noviembre de 2010 13:47, Marcelo Poli <enzomatrix en gmail.com>escribió:
>>
>> El día 16 de noviembre de 2010 13:35, Jorge Alvarez
>>> <asjorgealvarez en gmail.com> escribió:
>>> >
>>> >
>>> > Probé con la desactivación de todos los repositorios "extra" que fui
>>> > agregando en Otro Software mas Proposed y Backports pero el error se
>>> > mantiene igual. Lo que me llama la atención es que no pueda instalar el
>>> > sistema base de KDE y lo que imagino son librerías complementarias; eso
>>> > debería estar en los repos de Ubuntu, verdad?
>>> >
>>>
>>> Sí, KDE puede instalarse entero desde repositorios. Kubuntu es la
>>> prueba de ésto, así que la parte necesaria para que funcione K3b está
>>> y es mantenida oficialmente, así que es raro lo que está pasando.
>>> Saaaalvo que...
>>> Puede ser que algún paquete que se haya instalado por afuera de los
>>> repos oficiales esté generando la incompatibilidad. Lo que no se me
>>> ocurre es como encontrarlo.
>>>
>>> --
>>> Linux user #265467
>>> Ubuntu user # 8939
>>>
>>> --
>>> Ubuntu-ar lista de correo
>>> Ubuntu-ar en lists.ubuntu.com
>>> Modifica tus opciones o desuscribite en:
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-ar
>>> Siempre leer, comprender y aplicar nuestra etiqueta:
>>> https://wiki.ubuntu.com/ArgentinaTeam/EtiquetaML
>>>
>>>
>> Me imaginaba algo así... estuve googleando pero no encontré a nadie  que
>> tuviera un problema similar.
>>
>> --
>> Jorge Alvarez
>>
>
>
> Disculpen la insistencia pero tengo una duda, relacionada con éste tema: es
> posible que estén actualizando repositorios? porque intenté isntalar k3b en
> la notebook -que tiene un Maverick menos "tocado"- y me tiró el mismo error;
> usé los parámetros update y upgrade para arreglar un poco las cosas pero me
> quedaron 3 paquetes sin arreglar:
>
>
> No se pudieron instalar algunos paquetes. Esto puede significar que
> usted pidió una situación imposible o, si está usando la distribución
> inestable, que algunos paquetes necesarios no han sido creados o han
> sido movidos fuera de Incoming.
> La siguiente información puede ayudar a resolver la situación:
> *
>
> Los siguientes paquetes tienen dependencias incumplidas:
>  k3b : Depende: kdebase-runtime pero no va a instalarse
>        Depende: libk3b6 (= 2.0.1-1ubuntu3) pero no va a instalarse
>        Depende: libkde3support4 (>= 4:4.4.4) pero no va a instalarse
>        Depende: libqt4-qt3support (>= 4:4.5.3) pero no va a instalarse
> E: Paquetes rotos*
>
> No se me ocurre que otra cosa puede ser.
>
>
> Por probar otra cosa, quise instalar Videoporama (sudo apt-get install
> videoporama) y me di con:
>
> *
> Los siguientes paquetes tienen dependencias incumplidas:
>  videoporama : Depende: python-qt4 pero no va a instalarse
> E: Paquetes rotos*
>
> De nuevo la misma historia.
>
> Solo me queda pensar que están actualizando los repos, alguien sabe algo al
> respecto?
>
> --
> Jorge Alvarez
>


Una vez más para comentar la solución que encontré para el problema (en la
notebook funcionó, mañana veré en la de escritorio):

Recordé leer que aptitude es más robusto que apt-get. Entonces use aptitude
clean, purge, update y upgrade; traté de instalar k3b y luego de enumerar
decenas de dependencias incumplidas me sugería dejara sin actualizar algunas
librerías; elegí (N)o y me ofreció una segunda solución: desactualizar unas
cuantas librerías. Acepté la solución y ahora el sol brilla de nuevo, se
instaló k3b 2.01 y también videoporama.

Me queda la sospecha sobre la actualización parcial de los repos, sino, no
entiendo porqué al desactualizar algunas librerías todo funcionó de perlas.

Espero que la experiencia le sea útil a alguien.

Saludos.
-- 
Jorge Alvarez
------------ próxima parte ------------
Se ha borrado un adjunto en formato HTML...
URL: https://lists.ubuntu.com/archives/ubuntu-ar/attachments/20101117/d2f9df79/attachment.htm 


More information about the Ubuntu-ar mailing list