[ubuntu-ar] Ubuntu 10.10 y resolución de pantalla

Jorge Alvarez asjorgealvarez at gmail.com
Sun Dec 19 16:21:34 GMT 2010


El 19 de diciembre de 2010 03:36, Sebi Kul <sebikul en gmail.com> escribió:

> El 19/12/10 03:00, Jorge Alvarez escribió:
> >
> >
> > El 19 de diciembre de 2010 00:37, Juan <nouserfound en gmail.com
> > <mailto:nouserfound en gmail.com>> escribió:
> >
> >     Antes que nada, fijate si en el menú Sistema > Administracion >
> >     Controladores Adicionales, te sugiere instalar los drivers
> >     privativos de Nvidia. Si es asi, activalos, esperá se descarguen e
> >     instalen, y luego, reiniciá tu PC.
> >
> >     Si al reiniciar tu PC, no obtuviste la resolución deseada, desde una
> >     terminal ejecutá el siguiente comando:
> >     sudo nvidia-xconfig
> >     Eso creará automáticamente un xorg.conf ideal para tu Nvidia 7100.
> >     Reiniciá tu sesión de usuario, y debería funcionar.
> >
> >     Contanos cómo te fué!
> >
> >
> >     --
> >     Juan A. Wuethrich
> >
> >
> >     --
> >     Ubuntu-ar lista de correo
> >     Ubuntu-ar en lists.ubuntu.com <mailto:Ubuntu-ar en lists.ubuntu.com>
> >     Modifica tus opciones o desuscribite en:
> >     https://lists.ubuntu.com/mailman/listinfo/ubuntu-ar
> >     Siempre leer, comprender y aplicar nuestra etiqueta:
> >     https://wiki.ubuntu.com/ArgentinaTeam/EtiquetaML
> >
> >
> >
> > Muchas gracias por tu ayuda.
> >
> > Había probado de instalar los controladores adicionales; aparecían 2: la
> > 173 y la versión recomendada. Solo con ésta última logro un poco más.
> > Ahora estoy en los 1152x864 aunque compiz, que antes y aún en 640x480
> > andaba, desapareció sin dejar rastros.
> >
> > Intenté restaurando el archivo xorg.conf como explican aquí [0] pero no
> > obtuve ningún resultado.
> >
> > sudo nvidia-xconfig generó un xorg.conf pero sin ningún dato en
> > particular y tampoco mejoró la resolución de pantalla.
> >
> > Ahora me voy a dormir porque mi mujer me quiere matar. Mañana
> > investigaré poco más a ver que encuentro.
> >
> > Saludos
> >
> > [0] http://www.distrotest.es/?p=7725
> >
> >
> > --
> > Jorge Alvarez
> >
> Buenas!!
>
> Viendo que instalando los drivers de nvidia, estos no detectaron la
> resolución óptima, te recomiendo que hagas lo siguiente:
>
> Primero has un backup de tu xorg.conf ejecutando:
> $ sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
>
> luego ejecuta:
> $ gksudo gedit /etc/X11/xorg.conf
>
> Una vez abierto busca la linea que contenga:
> -----------------------------------------------
> Section "Screen"
> -----------------------------------------------
>
>
> Estara como un titulo con sub-secciones. una de ellas debería llamarse
> (si hay mas de uno elimina los que sobran):
> -----------------------------------------------
> SubSection "Display"
> -----------------------------------------------
>
>
> Bajo "SubSection "Display"" encontraras una linea que contiene algo
> similar a:
> -----------------------------------------------
> Modes   "1280x1024" "1024x768" "640x480"
> -----------------------------------------------
>
>
> Modificala para que quede asi:
> -----------------------------------------------
> Modes   "1680x1050"
> -----------------------------------------------
>
>
> En resumen, la parte del archivo debería quedarte algo así (solo como
> ejemplo, modifica únicamente la linea que mencione anteriormente):
> -----------------------------------------------
> Section "Screen"
>    Identifier     "Screen0"
>    Device         "Device0"
>    Monitor        "Monitor0"
>    DefaultDepth    24
>    SubSection "Display"
>        Depth           24
>        Modes   "1680x1050"
>    EndSubSection
> EndSection
> -----------------------------------------------
>
> Una vez hecho esto, reinicia y listo, ya estarás usando la resolución
> recomendada. Espero que esto te solucione tu problema.
>
> Saludos!!
>
> --
> Ubuntu-ar lista de correo
> Ubuntu-ar en lists.ubuntu.com
> Modifica tus opciones o desuscribite en:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-ar
> Siempre leer, comprender y aplicar nuestra etiqueta:
> https://wiki.ubuntu.com/ArgentinaTeam/EtiquetaML
>
>
>
Hola!

No hubo caso. Como dijiste había varias subsecciones Display, dejé solo una
y realicé los cambios como indicaste pero no pasó nada. Después usé xrandr y
me tiró con esto:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1152 x 864, maximum 1152 x 864
default connected 1152x864+0+0 0mm x 0mm
   1024x768       50.0     63.0
   800x600        51.0     52.0     53.0
   680x384        54.0     55.0
   640x480        56.0
   576x432        57.0
   512x384        58.0
   400x300        59.0     60.0     61.0
   320x240        62.0
   1152x864       63.0*

Luego encontré esta página [0] con varias indicaciones. En la parte final
muestra como agregar una resolución pero también me dio error, indicando que
no podía obtener el tamaño adecuado.

Me dio por pensar si no será que algo que encuentra en el /home está
jorobando. Quizás al reinstalar con el /home vacío funcione aunque no tengo
nada en particular, más que el compiz como viene de fábrica, con Expo
activado y sin cubo o llamas ni nada por el estio. También me llamó la
atención que define al monitor como CRT cuando es un LCD, pero no sé como
cambiar eso.

Saludos.

[0] https://wiki.ubuntu.com/X/Config/Resolution

-- 
Jorge Alvarez
------------ próxima parte ------------
Se ha borrado un adjunto en formato HTML...
URL: https://lists.ubuntu.com/archives/ubuntu-ar/attachments/20101219/c0a99eb5/attachment-0001.htm 


More information about the Ubuntu-ar mailing list