[ubuntu-ar] MySQL: Problemas, problemas.. y.. los mismos problemas.

Fabián Bonetti mama21mama2000 at yahoo.com.ar
Tue Aug 25 05:28:47 BST 2009


El mar, 25-08-2009 a las 01:17 -0300, Rodolfo Hugo González escribió:
> GS Warlus escribió:
> > *Hola, qué tal Ubunteros??
> > Me presento (creo que nunca antes participé en las listas, además de
> > leerla), mi nombre es Germán.
> > Estoy escribiendo este email (como adelanto en el Asunto) por el maldito
> > MySQL. La verdad, es que no se trata -me imagino- tanto de MySQL, sino
> > más bien se trata sobre el /dpkg/ ó no sé.
> > 
> > Estoy intentando instalarlo desde hace unos cuantos días, probé las
> > siguientes cosas:
> > *
> > 
> >     * *Instalarlo normalmente (repetidas veces) mediante /apt-get/ y
> >       /aptitude/. Tuve muchos problemas, donde tuve que recurrir al
> >       /dpkg-reconfigure /ó /dpkg --force-overwrite/ ó /dpkg -purge/,
> >       etc... etc... y nada.
> >       *
> >     * *Descargando paquetes (/RPM/, porque no los encontré como /DEB/ en
> >       la WebSite oficial de Sun; claro, usando /Alien /para
> >       "transformarlos"), y tampoco obtuve buenos resultados.*
> >     * *Usando "modos gráficos" (es decir, la misma leche, la misma
> >       calaña, porque en definitiva 'detrás' es lo mismo) como el
> >       /Synaptic/.*
> >     * *Borrando TODO archivo del directorio raíz (eludiendo el /home/ y
> >       el directorio //var/www/ por posibles problemas con /phpmyadmin /u
> >       otros que tengo instalados.
> >       *
> > 
> > *No tuve suerte. En fin, no es problema de dependencias... no es
> > problema de paquetes rotos... no sé dónde ni cuál es el verdadero problema.
> > Aquí les mando el _último_ código del último intento de instalación, a
> > ver si me pueden dar una mano... porque ya no se me ocurre más nada!!!! =S
> > 
> > Nota: probé los paquetes por defecto de los repositorios (5.0) y algunos
> > otros como el 5.1. Otro dato, los últimos errores me han venido después
> > de "lograr" la configuración root de MySQL, es decir, luego de poner las
> > contraseñas donde me aparece el primer errorcillo "*Error: #include
> > <abstractions/mysql> not found at line 9 in
> > /etc/apparmor.d/usr.sbin.mysqld. * Failure:
> > /etc/apparmor.d/usr.sbin.mysqld failed to load*"**.
> > **
> > *CÓDIGO DE SALIDA:
> > 
> >     Desempaquetando mysql-client-5.0 (de
> >     .../mysql-client-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb) ...
> >     Seleccionando el paquete mysql-server-core-5.0 previamente no
> >     seleccionado.                          
> >     Desempaquetando mysql-server-core-5.0 (de
> >     .../mysql-server-core-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb) ....
> >     Seleccionando el paquete mysql-server-5.0 previamente no
> >     seleccionado.                                         
> >     Desempaquetando mysql-server-5.0 (de
> >     .../mysql-server-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb)
> >     ...         
> >     Seleccionando el paquete libhtml-template-perl previamente no
> >     seleccionado.                                    
> >     Desempaquetando libhtml-template-perl (de
> >     .../libhtml-template-perl_2.9-1_all.deb) ...                         
> >     Seleccionando el paquete mysql-client previamente no
> >     seleccionado.                                             
> >     Desempaquetando mysql-client (de
> >     .../mysql-client_5.1.30really5.0.75-0ubuntu10.2_all.deb)
> >     ...                  
> >     Seleccionando el paquete mysql-server previamente no
> >     seleccionado.                                             
> >     Desempaquetando mysql-server (de
> >     .../mysql-server_5.1.30really5.0.75-0ubuntu10.2_all.deb)
> >     ...                  
> >     Procesando disparadores para man-db
> >     ...                                                                        
> > 
> >     Configurando mysql-client-5.0 (5.1.30really5.0.75-0ubuntu10.2)
> >     ...                                             
> >     Configurando mysql-server-core-5.0 (5.1.30really5.0.75-0ubuntu10.2)
> >     ...                                        
> >     Configurando mysql-server-5.0 (5.1.30really5.0.75-0ubuntu10.2)
> >     ...                                             
> >      * Stopping MySQL database server
> >     mysqld                                                                             
> >     [ OK ]
> >      * Reloading AppArmor profiles
> >     ...                                                                                          
> >     Error: #include <abstractions/mysql> not found at line 9 in
> >     /etc/apparmor.d/usr.sbin.mysqld.                                
> >      * Failure: /etc/apparmor.d/usr.sbin.mysqld failed to
> >     load                                                                  
> >                                                                                                                          
> >     [fail]
> >     Error: #include <abstractions/mysql> not found at line 9 in
> >     /etc/apparmor.d/usr.sbin.mysqld.                                
> >      * Starting MySQL database server
> >     mysqld                                                                             
> >     [fail]
> >     invoke-rc.d: initscript mysql, action "start" failed.
> >     dpkg: error al procesar mysql-server-5.0 (--configure):
> >      el subproceso post-installation script devolvió el código de salida
> >     de error 1
> >     Configurando libhtml-template-perl (2.9-1) ...
> >     Configurando mysql-client (5.1.30really5.0.75-0ubuntu10.2) ...
> >     dpkg: problemas de dependencias impiden la configuración de
> >     mysql-server:
> >      mysql-server depende de mysql-server-5.0; sin embargo:
> >      El paquete `mysql-server-5.0' no está configurado todavía.
> >     dpkg: error al procesar mysql-server (--configure):
> >      problemas de dependencias - se deja sin configurar
> >     No se ha escrito ningún informe de Apport porque el mensaje de error
> >     indica que es un error proveniente de un fallo anterior.
> >     Se encontraron errores al procesar:
> >      mysql-server-5.0
> >      mysql-server
> >     E: Sub-process /usr/bin/dpkg returned an error code (1)
> > 
> > 
> > *Espero me puedan ayudar. Gracias desde ya. Saludos!
> > /Germán./
> > *
> > 
> 
> Qué versión de SO tenés ?
> No estaba en el paquete o ISO original de donde instalaste el sistema
> operativo?
> 
> Eso es lo que me extraña. Yo instalé 8.10 original (de cd) y actualicé a
> 9.04. Pero a mi  todo lo de MySQL me vino de cajón.
> 
> Saludos
> 

Hola, si tanto problema te trae vas a tener que compilarlo.

Saludos



-- 


mama libre
http://mamalibre.eshost.com.ar 

--
------------ próxima parte ------------
Se ha borrado un mensaje que no est� en formato texto plano...
Nombre     : no disponible
Tipo       : application/pgp-signature
Tama�o     : 197 bytes
Descripci�n: Esta parte del mensaje =?ISO-8859-1?Q?est=E1?= firmada
 digitalmente
Url        : https://lists.ubuntu.com/archives/ubuntu-ar/attachments/20090825/3a4575dd/attachment.pgp 


More information about the Ubuntu-ar mailing list