[ubuntu-ar] vmware-player ya no está en 7.10?

Marcelo Fernandez fernandezm22 at yahoo.com.ar
Mon Nov 5 20:15:10 GMT 2007


Prof. Roman H. Gelbort escribió:
> Marcelo Fernandez escribió:
>   
>> Prof. Roman H. Gelbort escribió:
>>     
>>> Marcelo Fernandez escribió:
>>>   
>>>       
>>>> Prof. Roman H. Gelbort escribió:
>>>>     
>>>>         
>>>>> Resulta que para correr una aplicación determinada, sobre Ubuntu 7.04,
>>>>> tenía corriendo vmplayer, instalado con aptitude desde los repositorios
>>>>> corrientes y sin problemas.
>>>>>
>>>>> Cuando hice la actualización a 7.10 (usando el gestor de
>>>>> actualizaciones), no se actualizó este paquete y dejó de funcionar.
>>>>>
>>>>> Leí por la web que no se actualiza el repositorio automáticamente, así
>>>>> que lo hice a mano para seguir sin problemas (previamente había tratado
>>>>> de instalarlo a mano con "sudo aptitude install vmware-player" pero me
>>>>> daba un mensaje de error diciendo que no existia el paquete).
>>>>>
>>>>> Actualizado el repo, pensé que todo se solucionaría, pero en realidad
>>>>> siguió igual.
>>>>>
>>>>> ¿Alguien ya ha resuelto este problema?
>>>>>
>>>>> ¿Alguien que me quiera dar una mano para resolverlo?
>>>>>
>>>>>   
>>>>>       
>>>>>           
>>>> Sinceramente no sé si está, pero creo que ahora el repo donde está no se 
>>>> llama más "commercial", sino "partner". Fijate si lo tenés reflejado en 
>>>> tus repositorios.
>>>>
>>>> Saludos
>>>> Marcelo
>>>>
>>>>     
>>>>         
>>> El tema es este. Si hago una búsqueda, el paquete está...
>>>
>>> $ aptitude search vmware-player
>>> c   vmware-player                   - Free virtual machine player from
>>> VMware
>>> c   vmware-player-kernel-modules-2. - vmware-player modules for Linux
>>> (kernel 2.
>>>
>>> Pero si intento instalarlo me da esto...
>>>
>>> $ sudo aptitude install vmware-player
>>> [sudo] password for roman:
>>> Leyendo lista de paquetes... Hecho
>>> Creando árbol de dependencias
>>> Leyendo la información de estado... Hecho
>>> Leyendo la información de estado extendido
>>> Inicializando el estado de los paquetes... Hecho
>>> Construir la base de datos de etiquetas... Hecho
>>> No se encontró ninguna versión candidata para vmware-player
>>> No se instalará, actualizará o eliminará ningún paquete.
>>> 0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin
>>> actualizar.
>>> Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
>>> Escribiendo información de estado extendido... Hecho
>>> Leyendo lista de paquetes... Hecho
>>> Creando árbol de dependencias
>>> Leyendo la información de estado... Hecho
>>> Leyendo la información de estado extendido
>>> Inicializando el estado de los paquetes... Hecho
>>> Construir la base de datos de etiquetas... Hecho
>>>
>>> Mientras tanto, el archivo sources.list tiene esto...
>>>
>>> $ cat /etc/apt/sources.list
>>> deb http://ar.archive.ubuntu.com/ubuntu/ gutsy main restricted
>>> deb http://ar.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
>>> deb http://ar.archive.ubuntu.com/ubuntu/ gutsy universe
>>> deb http://ar.archive.ubuntu.com/ubuntu/ gutsy multiverse
>>> deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
>>> deb http://security.ubuntu.com/ubuntu gutsy-security universe
>>> deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
>>>
>>>
>>>   
>>>       
>> Es cierto, parece que no está:
>>
>> http://ubuntu-vb.blogspot.com/2007/10/vmware-player-en-gusty-gibbon-kernel.html
>> https://bugs.launchpad.net/ubuntu/+source/vmware-player/+bug/151424
>>
>> Podés usar el repo este:
>>
>> deb http://ppa.launchpad.net/cschieli/ubuntu gutsy main restricted 
>> universe multiverse
>>     
>
> Muchas gracias Marcelo!
>
> Ya está andando perfecto. Los pasos fueron (para cualquiera que lea esto
> a futuro):
>
> 1) Abrir con un editor de textos el archivo que tiene el listado de
> repositorios.
> 	sudo mcedit /etc/apt/sources.list
>
> 2) Agregar al final estas dos líneas:
> 	# Repositorio para vmware-player
> 	deb http://ppa.launchpad.net/cschieli/ubuntu gutsy main restricted
> universe multiverse
>
> 3) Actualizar la lista de paquetes del repositorio:
> 	sudo aptitude update
>
> 4) Instalar el paquete vmware-player
> 	sudo aptitude install vmware-player
>
> Luego de ese proceso (tuvo que descargar 72 Mb), ya está andando el
> vmplayer.
>
>   
Me alegro que te haya servido!

Y para los que le tienen miedo a la consola (terminal, o como le quieran 
llamar), para agregar un repositorio no hace falta más que ir a Sistema 
-> Administración -> Orígenes del Software. Una vez allí (y habiendo 
puesto la clave correspondiente), hay que ir a la pestaña que dice 
"Software de otros proveedores", hacer click en "Agregar", y poner "deb 
http://ppa.launchpad.net/cschieli/ubuntu gutsy main restricted universe 
multiverse".

Solito te  dice que la información de los repositorios "está 
desactualizada" y  haciendo click en "Recargar" se actualiza. Luego, hay 
que ir al Synaptic y agregar el paquete 'vmware-player'.

(Ojo, estoy frente a un Ubuntu Feisty y quizás se me escape algún 
detalle del procedimiento, aunque en general creo recordar que en Gutsy 
es igual).

Salutes

-- 
Marcelo F. Fernández
Buenos Aires, Argentina
Analista de Sistemas - CCNA

E-Mail: fernandezm22 en yahoo.com.ar
Jabber ID: fernandezm22 en jabber.org
Public Key ID: 5C990A6C 111C3661
Blog: http://marcelosoft.blogspot.com




More information about the Ubuntu-ar mailing list