Build a package using format 3.0 (quilt)

Allison Randal allison at lohutok.net
Fri Feb 24 23:25:17 UTC 2012


On 02/24/2012 12:12 PM, Víctor Fernández wrote:
> Hello. I'm trying to build a .deb package. But I need to use the format
> 3.0 (quilt) that requies an orig.tar file. The code is in python. I
> tryed to do a python setup.py sdist, and copy outside main directory.
> But when I try to build with dpkg-buildpackage, it trows an error
> (dpkg-source -b; error 255)

Hi Víctor,

Did you apply the patches to MANIFEST and MANIFEST.in? These make sure
that setup.py includes all the necessary files when it builds the
tarball. It's two separate revisions, revision 21 and revision 31, but
if you just pull the current versions of the two files from my branch,
you'll get all the relevant changes:

http://bazaar.launchpad.net/~allison/+junk/extras-guallet/view/head:/MANIFEST

http://bazaar.launchpad.net/~allison/+junk/extras-guallet/view/head:/MANIFEST.in


If that doesn't fix the problem, could you send the full command-line
output, and steps to reproduce the error?

Thanks,
Allison



More information about the Ubuntu-app-devel mailing list