Installing latest at-spi

Tony Bernedal tony at bernedal.net
Sat Jul 4 19:57:49 BST 2009


Hi.
I solved it by installing libgconf2-dev I hope I remember the name of
the library correct.
After installing this package I was abel to install all things correct
both on 32bit and 64bit.


2009/7/4, Bill Cox <waywardgeek at gmail.com>:
> I have similar warnings when building on Ubuntu 9.04 x64.  However, I
> don't get the last line:
>
> Makefile.am:13: GCONF_SCHEMAS_INSTALL does not appear in AM_CONDITIONAL
>
> I Googled GCONF_SCHEMAS_INSTALL, and found this:
>
> http://mail.gnome.org/archives/tracker-list/2006-October/msg00120.html
>
> My guess is the x32 source is a bit more recent than the x64, so
> you're seeing this bug while I don't.  It sounds like you should try
> commenting out the lines in Makefile.am, starting at 13.  It should
> look like:
>
> if GCONF_SCHEMAS_INSTALL
> #install-data-local:
>                 #if test -z "$(DESTDIR)" ; then \
>                         #for p in $(schemas_DATA) ; do \
>
> #GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL)
> --makefile-install-rule $(top_builddir)/data/$$p ; \
>                         #done \
>                 #fi
> #else
> install-data-local:
> #endif
>
> Hopefully that will work.
>
> Bill
>
>
> On Sat, Jul 4, 2009 at 10:51 AM, Storm Dragon<stormdragon2976 at gmail.com>
> wrote:
>> Hi,
>> I have tried to install the latest versions of atk and at-spi.  Atk
>> installed correctly, but I get errors when trying to install at-spi.
>> Here's
>> what I did, from the instructions on the Orca wiki:
>> http://live.gnome.org/Orca/DownloadInstall
>> ./autogen.sh --prefix=/usr --libexecdir=/usr/lib/at-spi
>> Returns several errors/warnings.  Here's the output from that command.
>> This
>> is on Ubuntu Jaunty 64 bit:
>> checking for autoconf >= 2.53...
>>   testing autoconf2.50... not found.
>>   testing autoconf... found 2.63
>> checking for automake >= 1.9...
>>   testing automake-1.10... found 1.10.2
>> checking for libtool >= 1.5...
>>   testing libtoolize... found 2.2.6
>> checking for glib-gettext >= 2.2.0...
>>   testing glib-gettextize... found 2.20.1
>> checking for intltool >= 0.30...
>>   testing intltoolize... found 0.40.6
>> checking for pkg-config >= 0.14.0...
>>   testing pkg-config... found 0.22
>> checking for gtk-doc >= 1.0...
>>   testing gtkdocize... found 1.11
>> Checking for required M4 macros...
>> Checking for forbidden M4 macros...
>> Processing ./configure.in
>> Running libtoolize...
>> libtoolize: putting auxiliary files in `.'.
>> libtoolize: copying file `./ltmain.sh'
>> libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in
>> libtoolize: rerunning libtoolize, to keep the correct libtool macros in
>> libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
>> Running glib-gettextize... Ignore non-fatal messages.
>> Copying file mkinstalldirs
>> Copying file po/Makefile.in.in
>>
>> Please add the files
>>   codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
>>   progtest.m4
>> from the /aclocal directory to your autoconf macro directory
>> or directly to your aclocal.m4 file.
>> You will also need config.guess and config.sub, which you can get from
>> ftp://ftp.gnu.org/pub/gnu/config/.
>>
>> Running intltoolize...
>> Running gtkdocize...
>> Running aclocal-1.10...
>> configure.in:50: warning: macro `AM_GCONF_SOURCE_2' not found in librar
>> Running autoconf...
>> Running autoheader...
>> autoheader: WARNING: Using auxiliary files such as `acconfig.h', `confi
>> autoheader: WARNING: and `config.h.top', to define templates for `confi
>> autoheader: WARNING: is deprecated and discouraged.
>> autoheader:
>> autoheader: WARNING: Using the third argument of `AC_DEFINE' and
>> autoheader: WARNING: `AC_DEFINE_UNQUOTED' allows one to define a templa
>> autoheader: WARNING: `acconfig.h':
>> autoheader:
>> autoheader: WARNING:   AC_DEFINE([NEED_FUNC_MAIN], 1,
>> autoheader: [Define if a function `main' is needed.])
>> autoheader:
>> autoheader: WARNING: More sophisticated templates can also be produced,
>> autoheader: WARNING: documentation.
>> Running automake-1.10...
>> atk-bridge/Makefile.am:23: libbonobo-2: non-POSIX variable name
>> atk-bridge/Makefile.am:23: liboaf-2: non-POSIX variable name
>> atk-bridge/Makefile.am:23: libORBit-2: non-POSIX variable name
>> atk-bridge/Makefile.am:23: libat-spi: non-POSIX variable name
>> docs/reference/idl/Makefile.am:18: <D: non-POSIX variable name
>> docs/reference/idl/Makefile.am:26: <D: non-POSIX variable name
>> Makefile.am:13: GCONF_SCHEMAS_INSTALL does not appear in AM_CONDITIONAL
>>
>> Check out the Storm Dragon blog:
>> http://www.stormdragon.us/
>>
>> --
>> Ubuntu-accessibility mailing list
>> Ubuntu-accessibility at lists.ubuntu.com
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-accessibility
>>
>>
>
> --
> Ubuntu-accessibility mailing list
> Ubuntu-accessibility at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-accessibility
>



More information about the Ubuntu-accessibility mailing list