Disappointed with Gutsy live (long)

Mike Reiser metalhead1009000 at gmail.com
Tue Oct 23 13:34:24 BST 2007

I share your disappointments, I can't even get the live CD to work here.  We've been basically excluded from the testing phase of this version also.  

  ----- Original Message ----- 
  From: Deborah Norling 
  To: ubuntu-accessibility at lists.ubuntu.com 
  Sent: Monday, October 22, 2007 11:06 PM
  Subject: Disappointed with Gutsy live (long)

  I like Ubuntu, because as they say, it usually "just works". I run a feisty-based server and helped my sighted husband set up MythTV on a pre-release of Gutsy.

  That's why I'm particularly disappointed with the newly released Gutsy live desktop CD. I'm posting this in detail in hopes that I've just missed something crucial.

  I played with the Feisty live CD back in March and April of this year, before and after it was released. I never successfully installed Feisty using Orca. I had no trouble at all with Ubuntu (any version) if I stuck to the alternate or server install CD, and installed using the serial port. But the problems I had with Feisty six months ago seem to still be occurring.

  Serial ports are disappearing from desktops so I want to be able to use Linux without needing to depend on speakup, hardware synthesizers  or serial consoles. At this point Linux is a hobby; I work as a Windows computer tech for a college. But I hope to eventually ditch Windows and even find employment working in a non-windows environment.

  I boot the Gutsy live desktop CD and press F5 for the access options. I press 3 or arrow down to it, to activate Orca. I press ENTER twice and wait a couple of minutes.

  Orca runs, and it seems to be working as well as it ever worked. It can't read help, which would seem to be the first thing a new user would want to do, but OpenOffice does work, so I presume it is happy with my hardware.

  I run brltty by quitting orca, running gnome-terminal, typing sudo su and on the next command line typing "brltty -bauto -d/dev/ttyUSB0".

  Brltty runs, but says the screen is not in text mode. Ok, guess even in a terminal, we aren't in text mode.

  It would be nice if this was better documented; the need to run brltty for Braille support, even though Braille support is already checked in the Orca preferences, the fact that even in gnome-terminal the screen is presumably not text-based, and the fact that help isn't working. I can add to the wiki of course. but would beginners know to look there? What about a readme on the CD, which auto-starts in Windows with a screen that's basically advertising for Ubuntu with no real information. Or maybe just a how-to page on the Ubuntu site that covers all this. I am eager to improve the docs, but I have to get it running first and know what I'm doing.

  Another disappointment: this is still brltty 3.72. The Orca wiki states that it's better to use 3.8 because it can be compiled with the python bindings -- so why is an older, less effective version on this new live CD?

  I run Orca again and now it is communicating with brltty. Python bindings or not, it seems to show everything in Braille just fine.

  On my Windows PC, I search the internet for information about installing Gutsy using Orca. Lots of info about conflicts with different versions of portaudio,  forum postings  about how cool it is that Ubuntu is accessible, but no definitive tutorial or how-to on installing. A few days ago, I found lots more information on fixing MythTV problems. It's disappointing that  there is so little information as I do believe strongly in RTFM.

  I've already tried the Install icon from the desktop with my husband reading the screen. He confirms that the install runs, but Orca can only echo keystrokes, it reads nothing in the install dialogs.

  I locate instructions on installing Feisty with Orca, the same wiki page I've myself contributed to. I follow those instructions, running gnome-terminal, typing sudo su, quitting orca, then running orca again with orca --disable-setup --disable main-window. I next type ubiquity, and the install runs, but still, Orca can't read any of it. Not even in flat review does it see anything.

  Between these tests I've done alt-ctrl-backspace to kill the X session, and brltty remains active, informing me that default boot scripts are being run. Each time Orca does automatically load and work with Braille. It crashes once, but I get it back easily, and the system seems generally stable. 

  At one point, I try running gparted as root, and though ps confirms that gparted is running, Orca can't read its screen either. Is orca only really able to let me access just a few "productivity" apps? I saw that Sun at CSUN had done a session on MythTV with Orca last year, so I'd expected Orca to work with a wide variety of software.

  I've tried this on several PCS and I can't figure out if Orca is really this undeveloped or I'm doing something wrong.

  I've looked on the wiki at what I presume are the latest release notes; they discuss details like the spell-checker working better in OpenOffice, Firefox 2 vs 3  and the bugginess of acroread. I'm grateful that so much hard work has gone in to working with the Firefox developers and scripting applications like Gaim, But I now just want to read the install dialogs.

  In theory, since X is client-server based, since all information is openly available, and because a whole ton of people are working hard on this project, Orca should be miles ahead of Windows screen readers like JAWS. I'm disappointed; I really want to ditch Windows, but how can I if access is this flaky still?



  Ubuntu-accessibility mailing list
  Ubuntu-accessibility at lists.ubuntu.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-accessibility/attachments/20071023/ab68bee7/attachment.htm 

More information about the Ubuntu-accessibility mailing list