[orca-list] speech-dispatcher 0.6.2

Guy Schlosser guyster at bex.net
Wed Jun 6 18:57:46 BST 2007

Hey there Tomas and other listers, this is really weird.  I modified 
the init.d script to point to the newly compiled speech-dispatcher, 
and on bootup, I receive the error message "can't create pid in 
/var/run/speech-dispatcher".  When I launch from the command ($sudo 
speech-dispatcher), this error does not occur.  Any ideas?  Again, 
thanks much in advance for all the help.



At 09:49 AM 6/4/2007, you wrote:
>Guy Schlosser wrote:
>>Hey Tomas, I'm running Ubuntu version 7.04.
>Well, this will involve a little bit of hacking.  The preferred 
>solution would be to wait for backport packages for Ubuntu 
>7.04.  I've heard that
>Luke Yelavich planned to make those available soon.
>If you don't want to wait, however, I'd suggest installing the 
>Ubuntu package for Speech Dispatcher 0.6.1.  This package includes 
>the startup scripts, which should work also with Speech Dispatcher 
>0.6.2.  You will just need to modify the startup script 
>/etc/init.d/speech-dispatcher to run the newer (compiled) version of 
>Speech Dispatcher.  This should involve changing the path to the 
>binary from /usr/bin/speech-dispatcher to 
>/usr/local/bin/speech-dispatcher or so, depending where your 
>compiled binary for 0.6.2 resides.
>Then you can test whether it worked out by invoking:
>/etc/init.d/speech-dispatcher restart
>and trying whether Speech Dispatcher speaks:
>spd-say hello
>Please note that I have never tried this and I'm not a Ubuntu 
>user.  I believe it should help, but you'll be the first one trying 
>it this way...
>Let me know if you have any problems.
>Best regards

More information about the Ubuntu-accessibility mailing list