eSpeak not Speaking with Speech-Dispatcher although Festival Does: Here're the Logs and Configs

Veli-Pekka Tätilä vtatila at
Mon Oct 2 00:26:14 BST 2006

Hi list,
Ok I've made some progress now. Thanks to a recent list post I learned how 
to enable universe which made a big difference. Turned out I didn't have 
speech-dispatcher installed, though Gnopernicus tried using it. Well now I 
do, after finding out how Synaptic is used, and have modded some config 
files. speech-dispatcher worked with Flite a while back but I had the same 
audio problems as with Festival. Now I'm trying to get it rolling with 
eSpeak which I've put in my home folder as a binary.

speak speaks to a wave file but I cannot get it working with speech 
dispatcher neither in Gnome via Gnopernicus nor by using the spd-say 
utility. I can hear no audio when it is supposed to speak. I read about a 
wave file method which writes out the audio data in a file and plays that. 
How do you configure this and does it write the file on disk or in memory?

As to the configs, here they are heavily snipped (,meaning all comments 
manually removed and work-wrapping corrected in my Windows terminal 
emulator). First of all the main config file to which I added espeak and 
have made no other changes myself (maybe Gnome did some, who knows):

vtatila at Sandbox:/etc/speech-dispatcher$ cat speechd.conf
IncludePath "/etc/speech-dispatcher/"
LogLevel  3
LogFile  "/var/log/speech-dispatcher/speech-dispatcher.log"
DefaultVolume 100

AddModule "flite"        "sd_flite"     "flite.conf" 
AddModule "festival"     "sd_festival"  "festival.conf" 
AddModule "espeak-generic" "sd_generic"   "espeak-generic.conf" 
DefaultModule espeak-generic

LanguageDefaultModule "en"  "flite"
LanguageDefaultModule "cs"  "festival"
LanguageDefaultModule "es"  "festival"

Include "clients/emacs.conf"
Include "clients/gnome-speech.conf"

And now the espeak specific config file. I got this on the Web and copy 
pasted it. The only thing I've changed is the tilde, as speak is in my home 
folder. This vtatila is the user I made upon installing Ubuntu and is what 
I'm currently using. wonder if speech-dispatcher looks into someone else's 
home. Under which user does it actually run speak? Anyway, here's the 

vtatila at Sandbox:/etc/speech-dispatcher/modules$ cat espeak-generic.conf
GenericExecuteSynth \
"echo \"$DATA\" | ~/speak -v $VOICE -s $RATE -a $VOLUME --stdin"

AddVoice        "en"    "male1"      "en"
AddVoice        "en"    "male2"      "en-b"
AddVoice    "en"    "MALEÂÂ3"    "en-d"
AddVoice   "en"   "FEMALE1"    "en-f"
AddVoice    "en"   "FEMALE2"   "en-fb"
AddVoice   "en"   "FEMALE3"   "en-fd"
3AddVoice   "en"    "CHILD_MALE"    "en-c"
AddVoice    "en"    "CHILD_FEMALE"    "en-fc"

GenericLanguage "en" "english"
GenericRateAdd 250
GenericVolumeAdd 10
GenericRateMultiply 100
GenericVolumeMultiply 10
GenericRateForceInteger 1
GenericVolumeForceInteger 1
 Debug 0

Finally, here's how the log file looks after trying to use Gnopernicus for a 
while and running the spd-say command twice.

[Mon Oct  2 04:19:54 2006 : 74637] speechd:   Reading configuration for 
[Mon Oct  2 04:19:54 2006 : 78147] speechd:   Reading configuration for 
[Mon Oct  2 04:19:54 2006 : 78219] speechd:  Configuration has been read 
from "/
[Mon Oct  2 04:19:54 2006 : 78243] speechd:   Speech Dispatcher started with 
2 o
utput modules
[Mon Oct  2 04:19:54 2006 : 78296] speechd:   Openning socket connection
[Mon Oct  2 04:19:54 2006 : 81978] speechd: Speech Dispatcher waiting for 
s ...
[Mon Oct  2 04:25:09 2006 : 830105] speechd:   Connection closed
[Mon Oct  2 04:27:09 2006 : 737609] speechd:   Connection closed

Hope this helps in troubleshooting at least, <grin>.

With kind regards Veli-Pekka Tätilä (vtatila at
Accessibility, game music, synthesizers and programming: 

More information about the Ubuntu-accessibility mailing list