So, what's the story on ESD? (was, Re: Help troubleshooting major gnome-speech issue?)

Al Puzzuoli alpuzz at
Mon Jul 10 20:36:51 BST 2006

Hello Javier,

Thank you very much, disabling ESD did seem to resolve the issue.  However, 
I'm confused because  this machine worked for a long time with ESD enabled 
then at some point, it suddenly became a problem.

The system in question is an IBM Thinkpad T43, with an integrated Intel 
sound chip that uses the ac97 codec.

Can anyone speak as to what the issue is here?  are we dealing with some 
sort of BUG in ESD, a limitation of Alsa or something else?
I would assume that ideally, it would be desirable to keep ESD enabled, 
especially if the machine will be used for any multimedia related 



----- Original Message ----- 
From: "Fco. Javier Dorado Martínez" <javier at>
To: "Al Puzzuoli" <alpuzz at>
Cc: <ubuntu-accessibility at>
Sent: Monday, July 10, 2006 4:20 AM
Subject: Re: Help troubleshooting major gnome-speech issue?

> Hi to all
> Al, try to disable the ESD sound system. Goto the menu, system,
> preferences, sound and uncheck the checkbox using ESD.
> Regards,
> Javier.
> :On Sun, Jul 09,
> 2006 at 11:32:05PM -0400, Al Puzzuoli wrote:
>> Hello everyone,
>> I'm seeing some really major weirdness on my dapper system, I believe 
>> with gnome-speech, but I'm not even sure whether gnome-speech itself is 
>> the culprit.
>> Basically, what happens is that upon booting my machine, I log into 
>> gnome, and then get no speech when attempting to run Orca or gnopernicus, 
>> either with Festival or Fonix DECtalk.
>> A couple interesting points.  This issue does not occur 100% of the time. 
>> If I reboot 5 times, I would say 4 out of the 5 times, I get no speech, 
>> and then the fifth time, everything is fine.  When the problem does 
>> occur, if I issue the reboot command from a virtual console, then speech 
>> momentarily starts as processes are being shut down.
>>   If I run test-speech before ever logging into X, both Festival and 
>> DECtalk consistently work as expected.
>> I've tried rebuilding gnome-speech, but to no avail.
>> i'm typically not one to shy away from a bit of troubleshooting, but the 
>> frustrating thing is that I really don't have anything to sink my teeth 
>> into.  I have spoken to others who have had similar problems, but for the 
>> most part, the lack of speech seems to be the exception rather than the 
>> rule, where as on my system, the opposite is the case.
>> If anyone can offer ideas, they would be very much appreciated.  At this 
>> point, I'm becoming increasingly tempted to torch the whole thing and 
>> simply reinstall, but I  hate leaving problems like this unresolved.
>> --Al
>> -- 
>> Ubuntu-accessibility mailing list
>> Ubuntu-accessibility at

More information about the Ubuntu-accessibility mailing list