[ubuntu/trusty-security] libxfont 1:1.4.7-1ubuntu0.4 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Wed Nov 29 17:55:09 UTC 2017


libxfont (1:1.4.7-1ubuntu0.4) trusty-security; urgency=medium

  * SECURITY UPDATE: non-privileged arbitrary file access
    - debian/patches/CVE-2017-16611-pre.patch: set close-on-exec for font
      file I/O in src/fontfile/fileio.c, src/fontfile/filewr.c.
    - debian/patches/CVE-2017-16611.patch: open files with O_NOFOLLOW in
      src/fontfile/dirfile.c, src/fontfile/fileio.c.
    - CVE-2017-16611

Date: 2017-11-29 15:04:13.006344+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/libxfont/1:1.4.7-1ubuntu0.4
-------------- next part --------------
Sorry, changesfile not available.


More information about the Trusty-changes mailing list