[ubuntu/trusty-updates] libgd2 2.1.0-3ubuntu0.2 (Accepted)

Ubuntu Archive Robot cjwatson+ubuntu-archive-robot at chiark.greenend.org.uk
Mon Jul 11 17:58:48 UTC 2016


libgd2 (2.1.0-3ubuntu0.2) trusty-security; urgency=medium

  * SECURITY UPDATE: out of bounds read in gdImageScaleTwoPass
    - debian/patches/CVE-2013-7456.patch: properly handle window size in
      src/gd_interpolation.c.
    - CVE-2013-7456
  * SECURITY UPDATE: stack overflow with large names
    - debian/patches/CVE-2016-5116.patch: properly handle names in
      src/gd_xbm.c.
    - CVE-2016-5116
  * SECURITY UPDATE: integer overflow in _gd2GetHeader()
    - debian/patches/CVE-2016-5766.patch: check for overflow in
      src/gd_gd2.c.
    - CVE-2016-5766
  * SECURITY UPDATE: denial of service via invalid color index
    - debian/patches/CVE-2016-6128.patch: check color index in
      src/gd_crop.c, added test to tests/CMakeLists.txt, tests/Makefile.am,
      tests/gdimagecrop/php_bug_72494.c.
    - CVE-2016-6128
  * SECURITY UPDATE: out of bounds read of masks array
    - debian/patches/CVE-2016-6161.patch: properly handle EOF marker in
      src/gd_gif_out.c.
    - CVE-2016-6161

Date: 2016-07-08 19:03:13.529009+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
Signed-By: Ubuntu Archive Robot <cjwatson+ubuntu-archive-robot at chiark.greenend.org.uk>
https://launchpad.net/ubuntu/+source/libgd2/2.1.0-3ubuntu0.2
-------------- next part --------------
Sorry, changesfile not available.


More information about the Trusty-changes mailing list