[ubuntu/trusty-security] gdk-pixbuf 2.30.7-0ubuntu1.2 (Accepted)

Steve Beattie sbeattie at ubuntu.com
Tue Oct 13 19:22:35 UTC 2015


gdk-pixbuf (2.30.7-0ubuntu1.2) trusty-security; urgency=medium

  * SECURITY UPDATE: Heap overflow and DoS with tga files
    - debian/patches/CVE-2015-7673-1.patch: pass on OOM conditions in
      make_weights functions in gdk-pixbuf/pixops/pixops.c
    - debian/patches/CVE-2015-7673-2.patch: Wrap TGAColormap struct in
      its own API in gdk-pixbuf/io-tga.c
    - debian/patches/CVE-2015-7673-3.patch: always parse colormaps in
      gdk-pixbuf/io-tga.c
  * SECURITY UPDATE: heap overflow when scaling GIF images
    - debian/patches/CVE-2015-767.patch: ensure variables are large
      enough when shifting bits in gdk-pixbuf/pixops/pixops.c

Date: 2015-10-10 13:24:12.964543+00:00
Changed-By: Steve Beattie <sbeattie at ubuntu.com>
https://launchpad.net/ubuntu/+source/gdk-pixbuf/2.30.7-0ubuntu1.2
-------------- next part --------------
Sorry, changesfile not available.


More information about the Trusty-changes mailing list