[ubuntu/trusty-security] libxml2 2.9.1+dfsg1-3ubuntu4.5 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Mon Nov 16 18:10:58 UTC 2015


libxml2 (2.9.1+dfsg1-3ubuntu4.5) trusty-security; urgency=medium

  * SECURITY UPDATE: denial of service via XEE attack
    - debian/patches/CVE-2015-1819.patch: enforce the reader to run in
      constant memory in buf.c, include/libxml/tree.h, xmlreader.c.
    - CVE-2015-1819
  * SECURITY UPDATE: denial of service via out-of-bounds read
    - debian/patches/CVE-2015-7941.patch: stop parsing on entities
      boundaries errors in parser.c.
    - CVE-2015-7941
  * SECURITY UPDATE: overflow in conditional sections
    - debian/patches/CVE-2015-7942.patch: properly check input in parser.c.
    - CVE-2015-7942
  * SECURITY UPDATE: denial of service via crafted document with xz
    - debian/patches/CVE-2015-8035.patch: check for error in xzlib.c.
    - CVE-2015-8035

Date: 2015-11-13 14:36:17.702380+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/libxml2/2.9.1+dfsg1-3ubuntu4.5
-------------- next part --------------
Sorry, changesfile not available.


More information about the Trusty-changes mailing list