[ubuntu/trusty-proposed] fglrx-installer 2:15.200-0ubuntu0.2 (Accepted)

Alberto Milone alberto.milone at canonical.com
Fri Apr 17 15:03:43 UTC 2015


fglrx-installer (2:15.200-0ubuntu0.2) trusty-proposed; urgency=medium

  * debian/control.in:
    - Allow the -core package to overwrite files that belong to
      fglrx. This prevents errors caused by the split into fglrx
      and fglrx-core (LP: #1443016, LP: #1129409).

fglrx-installer (2:15.200-0ubuntu0.1) trusty-proposed; urgency=medium

  * New upstream release:
    - Add support for X ABI 19.
  * debian/control.in, debian/com.ubuntu.amdcccle.pkexec.policy,
    debian/rules, debian/fglrx.dirs.in,
    debian/fglrx.install.in,
    debian/fglrx.links.in,
    debian/fglrx.postinst.in,
    debian/fglrx.postrm.in,
    debian/fglrx.preinst.in,
    debian/fglrx.prerm.in,
    debian/fglrx.grub-gfxpayload.in,
    debian/overrides/fglrx.in,
    debian/overrides/fglrx-core.in,
    debian/overrides/fglrx-dev.in,
    debian/fglrx-amdcccle.dirs.in,
    debian/fglrx-amdcccle.install.in,
    debian/fglrx-core.dirs.in,
    debian/fglrx-core.links.in,
    debian/fglrx-core.postinst.in,
    debian/fglrx-core.postrm.in,
    debian/fglrx-core.preinst.in,
    debian/fglrx-core.prerm.in,
    debian/fglrx-core.postrm.in:
    - Drop conflicts/provides/replaces libopencl1 and provide
      opencl-icd (LP: #1129409).
    - Make amdcccle depend on polkit-1.
    - Use pkexec for amdcccle when running Unity.
    - Split the minimal driver into the -core package.
    - Depend on the "file" package.
  * debian/fglrx-dev.links.in:
    - Add links for libOpenCL libGL.so, libAMDXvBA, libXvBAW.
  * debian/substvars:
    - Add support for X ABI 18 and 19.
  * debian/patches/series, amdxdg-su-add-support-for-pkexec.patch:
    - Leave the patch disabled for future reference and easier
      backporting.
  * debian/patches/call-amdcccle-with-full-path.diff:
    - Pass amdxdg the full path.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.15.patch,
    debian/dkms/patches/buildfix_kernel_3.17.patch,
    debian/dkms/patches/buildfix_kernel_3.19.patch:
    - Add support for Linux 3.15-3.19.
    - Leave the patches disabled for future reference and easier
      backporting.
    - Correct a typo that caused an incorrect dkms.conf to be
      generated from the template.
  * debian/71-fglrx.rules:
    - Tag the device for logind.

Date: Thu, 16 Apr 2015 12:01:05 +0200
Changed-By: Alberto Milone <alberto.milone at canonical.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.200-0ubuntu0.2
-------------- next part --------------
Format: 1.8
Date: Thu, 16 Apr 2015 12:01:05 +0200
Source: fglrx-installer
Binary: fglrx-core fglrx fglrx-dev fglrx-amdcccle
Architecture: source
Version: 2:15.200-0ubuntu0.2
Distribution: trusty-proposed
Urgency: medium
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Alberto Milone <alberto.milone at canonical.com>
Description: 
 fglrx      - Video driver for the AMD graphics accelerators
 fglrx-amdcccle - Catalyst Control Center for the AMD graphics accelerators
 fglrx-core - Minimal video driver for the AMD graphics accelerators
 fglrx-dev  - Video driver for the AMD graphics accelerators (devel files)
Launchpad-Bugs-Fixed: 1129409 1443016
Changes: 
 fglrx-installer (2:15.200-0ubuntu0.2) trusty-proposed; urgency=medium
 .
   * debian/control.in:
     - Allow the -core package to overwrite files that belong to
       fglrx. This prevents errors caused by the split into fglrx
       and fglrx-core (LP: #1443016, LP: #1129409).
 .
 fglrx-installer (2:15.200-0ubuntu0.1) trusty-proposed; urgency=medium
 .
   * New upstream release:
     - Add support for X ABI 19.
   * debian/control.in, debian/com.ubuntu.amdcccle.pkexec.policy,
     debian/rules, debian/fglrx.dirs.in,
     debian/fglrx.install.in,
     debian/fglrx.links.in,
     debian/fglrx.postinst.in,
     debian/fglrx.postrm.in,
     debian/fglrx.preinst.in,
     debian/fglrx.prerm.in,
     debian/fglrx.grub-gfxpayload.in,
     debian/overrides/fglrx.in,
     debian/overrides/fglrx-core.in,
     debian/overrides/fglrx-dev.in,
     debian/fglrx-amdcccle.dirs.in,
     debian/fglrx-amdcccle.install.in,
     debian/fglrx-core.dirs.in,
     debian/fglrx-core.links.in,
     debian/fglrx-core.postinst.in,
     debian/fglrx-core.postrm.in,
     debian/fglrx-core.preinst.in,
     debian/fglrx-core.prerm.in,
     debian/fglrx-core.postrm.in:
     - Drop conflicts/provides/replaces libopencl1 and provide
       opencl-icd (LP: #1129409).
     - Make amdcccle depend on polkit-1.
     - Use pkexec for amdcccle when running Unity.
     - Split the minimal driver into the -core package.
     - Depend on the "file" package.
   * debian/fglrx-dev.links.in:
     - Add links for libOpenCL libGL.so, libAMDXvBA, libXvBAW.
   * debian/substvars:
     - Add support for X ABI 18 and 19.
   * debian/patches/series, amdxdg-su-add-support-for-pkexec.patch:
     - Leave the patch disabled for future reference and easier
       backporting.
   * debian/patches/call-amdcccle-with-full-path.diff:
     - Pass amdxdg the full path.
   * debian/dkms.conf.in,
     debian/dkms/patches/buildfix_kernel_3.15.patch,
     debian/dkms/patches/buildfix_kernel_3.17.patch,
     debian/dkms/patches/buildfix_kernel_3.19.patch:
     - Add support for Linux 3.15-3.19.
     - Leave the patches disabled for future reference and easier
       backporting.
     - Correct a typo that caused an incorrect dkms.conf to be
       generated from the template.
   * debian/71-fglrx.rules:
     - Tag the device for logind.
Checksums-Sha1: 
 6615d1ff431219460cb8c11a3d3ab33887982498 2267 fglrx-installer_15.200-0ubuntu0.2.dsc
 2732a74725ee4bd11d71ae150ce16f148425228d 62794 fglrx-installer_15.200-0ubuntu0.2.debian.tar.gz
Checksums-Sha256: 
 87ff92f83c112e3c2e24deb57c1c3fb93b72d2fb4a3305206a21f1d04fe9e426 2267 fglrx-installer_15.200-0ubuntu0.2.dsc
 86ef91aeda192f361450995ece0167208780f3427e7720594b482911a4541b67 62794 fglrx-installer_15.200-0ubuntu0.2.debian.tar.gz
Files: 
 cc940d873cf31f803d4c449241d90b28 2267 restricted/misc extra fglrx-installer_15.200-0ubuntu0.2.dsc
 5599909e247c514e43f0b84856f1779d 62794 restricted/misc extra fglrx-installer_15.200-0ubuntu0.2.debian.tar.gz


More information about the Trusty-changes mailing list