[ubuntu/trusty-security] samba 2:4.1.6+dfsg-1ubuntu2.14.04.2 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Thu Jun 26 17:20:31 UTC 2014


samba (2:4.1.6+dfsg-1ubuntu2.14.04.2) trusty-security; urgency=medium

  * SECURITY UPDATE: info leak via SRV_SNAPSHOT_ARRAY response field
    - debian/patches/CVE-2014-0178.patch: don't return uninitialized data
      and extra bytes in source3/modules/vfs_default.c.
    - CVE-2014-0178
  * SECURITY UPDATE: denial of service via forged DNS response
    - debian/patches/CVE-2014-0239.patch: don't reply to replies in
      source4/dns_server/dns_server.c, added test to
      python/samba/tests/dns.py.
    - CVE-2014-0239
  * SECURITY UPDATE: denial of service on nmbd malformed packet
    - debian/patches/CVE-2014-0244.patch: return on EWOULDBLOCK/EAGAIN in
      source3/lib/system.c.
    - CVE-2014-0244
  * SECURITY UPDATE: denial of service via bad unicode conversion
    - debian/patches/CVE-2014-3493.patch: refactor code in
      source3/lib/charcnv.c, change return code checks in
      source3/libsmb/clirap.c, source3/smbd/lanman.c.
    - CVE-2014-3493

Date: 2014-06-25 16:59:17.080842+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/trusty/+source/samba/2:4.1.6+dfsg-1ubuntu2.14.04.2
-------------- next part --------------
Sorry, changesfile not available.


More information about the Trusty-changes mailing list